Memory Exceeded given limit

Hello! I am currently coding a bot in the editor and for some reason it started to show me in the container that the project’s memory was above 900MB, even though I have nothing weird to make it act like that. The project stops all the time because of this exceeding.
Could anyone help me fix this?

Project name: t-music-bot

Thanks in advance,

@TehPig_YT, please email Glitch at for help with memory limits.

Also, try removing unwanted packages and run enable-pnpm.

I have only 6 packages, this is not the problem :expressionless:

what kind of project is it? The startup of some packages or a loop can be very heavy

It’s easy to understand when looking at the keywords of this topic :expressionless:

it’s in the wrong category then. What other packages than discord.js do you have?

Firstly, it’s not in the wrong category, since this is based on unexpected glitch container change.

"dependencies": {
    "@discordjs/opus": "^0.3.2",
    "express": "^4.17.1",
    "simple-youtube-api": "^5.2.1",
    "ytdl-core": "^2.1.2",
    "discord.js-light": "^2.6.2",
    "util": "^0.12.3"

The packages are not the problem.

1 Like

try this: remove discord.js light and @discordjs/opus. Use the normal discord.js: "discord.js": "^12.2.0", secondly, there’s a special category for discord bots, which replies normally faster

Firstly, this is not a topic for discord.js, if you understand and
Secondly, I’m not going to use discord.js as it was working before as it is.

Don’t try to change my mind, this referring to glitch staff, as they are the only who can help with this
Have a nice day.

ok I solved my problem by regenerating the Token (working now). I’m just trying to help as Glitch Staff is busy with so many requests, that’s why this is called a community

Have a nice day

Your problem is not related to mine.

Actually it was :frowning:

Refrshing your token worked? Surprising.

I have just contacted their support server for a fix.
It was working fine though some hours ago and I cannot understand why.

No, it didn’t, I have to remove the package for it to work.
But the whole project is depending on it.

Problem has been fixed from the creator of the package :upside_down_face:

:ok_hand: Happy to hear that

that fix worked for a while, then i got to delete the bot (had 1 server, no worries) and create it again probably discord.js stuck at the gateway :neutral_face:

He’s still referring to me -_-
If you want to talk with others about your problem, go to your own topic please.