Modules Not Installing

node v12.0.0, with pnpm
/opt/watcher/app-types/node/ line 110: [: !=: unary operator expected
Performing headless installation
 WARN  Cannot find file at /rbd/pnpm-volume/3a75859a-8951-4654-8fd9-e70ea62816e6/node_modules/better-sqlite3 although it was listed by readdir
 WARN  Cannot find file at /rbd/pnpm-volume/3a75859a-8951-4654-8fd9-e70ea62816e6/node_modules/bindings although it was listed by readdir
 WARN  There's a directory in node_modules without package.json: /rbd/pnpm-volume/3a75859a-8951-4654-8fd9-e70ea62816e6/node_modules/prebuild-install
Total install time: 3465ms
    throw err;
Error: Cannot find module 'better-sqlite3'
Require stack:
- /rbd/pnpm-volume/3a75859a-8951-4654-8fd9-e70ea62816e6/node_modules/
- /rbd/pnpm-volume/3a75859a-8951-4654-8fd9-e70ea62816e6/node_modules/
- /app/server.js
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:610:15)
    at Function.Module._load (internal/modules/cjs/loader.js:526:27)
    at Module.require (internal/modules/cjs/loader.js:666:19)
    at require (internal/modules/cjs/helpers.js:16:16)
    at new Enmap (/rbd/pnpm-volume/3a75859a-8951-4654-8fd9-e70ea62816e6/node_modules/
at Object.<anonymous> (/app/server.js:7:15)
    at Module._compile (internal/modules/cjs/loader.js:759:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:770:10)
    at Module.load (internal/modules/cjs/loader.js:628:32)
    at Function.Module._load (internal/modules/cjs/loader.js:555:12)

^ I try installing better-sqlite3 with both the built-in button in package.json and pnpm i better-sqlite3, but it keeps throwing the error that it wasn’t installed.

Node Version: 12.x
When installing with pnpm in console:

A store server is running. All store manipulations are delegated to it.
Resolving: total 61, reused 47, downloaded 0
Packages: +1
 ERROR  ENOENT: no such file or directory, chmod '/rbd/pnpm-volume/3a75859a-8951-4654-8fd9-e70ea62816e6/node_modules/'

Link to Glitch Project:!/elo-ripoff

Please help ;(

Can you try npm rebuild?

I tried that. I recently just tried enable pnpm and it worked! How do I close this topic?

1 Like

Just mark your post as ‘Solution’ , that should do the trick.