Multiple Instances and error

Hey, so my application is first of all running two different instances of the bot, and I confirmed it’s only that host that’s hosting it. Tried remixing and disabling old one, no luck.

Now, error I get:

(node:12562) UnhandledPromiseRejectionWarning: SqliteError: database disk image is malformed
at Map.fetchEverything (/rbd/pnpm-volume/f0977589-aa98-4b9e-96cf-8c034d06389c/node_modules/
at Map.[init] (/rbd/pnpm-volume/f0977589-aa98-4b9e-96cf-8c034d06389c/node_modules/
at <anonymous>
at process._tickCallback (internal/process/next_tick.js:189:7)
at Function.Module.runMain (module.js:696:11)
at startup (bootstrap_node.js:204:16)
at bootstrap_node.js:625:3
(node:12562) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1)
(node:12562) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

I use enmaps (which uses better-sqllite-pool) for data storing, and seems like it’s a issue relating to it. Tried uninstalling and reinstalling and all that

my project is!/cas-mod
had the multiple instance glitch before, don’t know how I solved. Never had the error above tho

MOD EDIT: formatting

Hey @Cyberbullie that error looks to me like your database file is corrupted. Not sure what you’re storing in there, but if you can get by with just starting fresh you should be able to delete your .sqlite file.

Thank you, never would’ve thought it was the files themselves. Turns out the instances glitch was something on my end, and I’ve since fixed it. Thank you very much

1 Like