Music bot prob (again) ;-;

#1

I could not join the voice channel: Error: Could not locate the bindings file. Tried:
→ /rbd/pnpm-volume/d579fd31-d90c-4758-a32a-da074bd710e8/node_modules/.registry.npmjs.org/node-opus/0.3.1/node_modules/node-opus/build/node-opus.node
→ /rbd/pnpm-volume/d579fd31-d90c-4758-a32a-da074bd710e8/node_modules/.registry.npmjs.org/node-opus/0.3.1/node_modules/node-opus/build/Debug/node-opus.node
→ /rbd/pnpm-volume/d579fd31-d90c-4758-a32a-da074bd710e8/node_modules/.registry.npmjs.org/node-opus/0.3.1/node_modules/node-opus/build/Release/node-opus.node
→ /rbd/pnpm-volume/d579fd31-d90c-4758-a32a-da074bd710e8/node_modules/.registry.npmjs.org/node-opus/0.3.1/node_modules/node-opus/out/Debug/node-opus.node
→ /rbd/pnpm-volume/d579fd31-d90c-4758-a32a-da074bd710e8/node_modules/.registry.npmjs.org/node-opus/0.3.1/node_modules/node-opus/Debug/node-opus.node
→ /rbd/pnpm-volume/d579fd31-d90c-4758-a32a-da074bd710e8/node_modules/.registry.npmjs.org/node-opus/0.3.1/node_modules/node-opus/out/Release/node-opus.node
→ /rbd/pnpm-volume/d579fd31-d90c-4758-a32a-da074bd710e8/node_modules/.registry.npmjs.org/node-opus/0.3.1/node_modules/node-opus/Release/node-opus.node
→ /rbd/pnpm-volume/d579fd31-d90c-4758-a32a-da074bd710e8/node_modules/.registry.npmjs.org/node-opus/0.3.1/node_modules/node-opus/build/default/node-opus.node
→ /rbd/pnpm-volume/d579fd31-d90c-4758-a32a-da074bd710e8/node_modules/.registry.npmjs.org/node-opus/0.3.1/node_modules/node-opus/compiled/10.15.0/linux/x64/node-opus.node
well…

1 Like

#2

Hey @ChaosPhoe, this typically indicates an intermittent package install failure, and running enable-pnpm in the console often solves it. Can you give that a try?

1 Like

#3

tried that already, didn’t work ;-;

1 Like

#4

Hello! @ChaosPhoe,

Sometimes this error could be caused by an outdated package, or node version, can you make sure all packages work with the version of node you are using, and tell me if that helps in anyway!

0 Likes

#5

We can also take a closer look, but will need your project name to do so.

1 Like

#7

nah all were updated :confused:

1 Like

#8

The project name is chaos12

1 Like

#9

Looking at your package.json file, you have node called out in your dependencies. That can cause installation problems; if you need a specific version of node you can specify it in the engines field.

If you remove that (and perhaps enable-pnpm again) does that help resolve this?

1 Like