My discord bot im trying to get to work. I am not getting any errors in logs or console but my bot wont turn to being online PLZ HELP

it is failing to start because of a code error. in logs saying something in server.js

if screenshots will help happy to provide

Hey @bgbuddyboy,

Could you share a screenshot of the error? Or can you tell what the error is exactly, as shown in the logs?

This post was flagged by the community and is temporarily hidden.

I’m sorry, but can you also send what is above the error in the screenshot given?

You will be able to remix the project and run it yourself, @khalby786. It is not private.

Regards,
Ares

This post was flagged by the community and is temporarily hidden.

Hey @bgbuddyboy,

I think I’ve found it! In line 12 of your server.js, you have the code:const discordBot = require("./bot");. But ./bot does not exist!

so just delete that line?

Try commenting that line, so that we can see if that is the problem.

This post was flagged by the community and is temporarily hidden.

Does the project have an index.html?

No, I have left the link to the project in original post if that will help

Can you try adding this line in your server.js?

app.get("/", (request, response) => {
  response.sendStatus(200);
});

Done that. in project site says OK

Bot still offline

Just as a precaution, can you update your package.json like this:?

{
  "name": "BadLands",
  "version": "1.0.0",
  "description": "",
  "main": "index.js",
  "scripts": {
    "test": "echo \"Error: no test specified\" && exit 1",
    "start": "node server.js"
  },
  "engines": {
    "node": "8.x"
  },
  "author": "",
  "license": "ISC",
  "dependencies": {
    "botkit-discord": "^0.1.3",
    "express": "^4.17.1",
    "uptime-robot": "^1.3.0",
    "dotnet-2.2": "^2.2.1005"
  }
}

can we move to a discord server as links were just disabled

getting new error in logs

if you want add me on disc: bgbuddyboy#2821

@bgbuddyboy, I’ve sent you a Discord server invite link.

Ok, so right now, there are no errors, but the bot is down (according to Uptime Robot)!

Is there anything I could help out with?
-Happy Glitching tech_dude1

yes i do thanks
I have limited reply’s so better to chat else where.

There is nothing in console or logs but the bot won’t turn on

If want to you can add me on discord: bgbuddyboy#2821