My project cant run

Hi,I finish my discord bot today,I worked few days for it,I already check my bot while resume coding but today its not opening,I cant run my bot,also when I open my bot link,it never opens,help please

Hey there, Glitch had an outage recently. See this thread: Some projects are having trouble connecting in the editor. However, it has been marked as solved. So you should be able to visit your projects/open the editor.

I see,refresh,reopen but still cant run,should I send mail about that?

Hi, can you look in the logs? If thete’s something about a 429 error or too many requests, please post your project name in this topic and the Glitch staff will fix it as soon as possible.
The reason you don’t see anything when you go to the project is because you don’t have any routing to files - look up how to use express and just add that to your main file to see something when it loads.
I hope this helps!

1 Like

No mate,when I see logs,there is no problem,everything fine,but I download files my pc and click start.bat , and I take “cannot find module discord.js” error,any solution?

Now,log give error,its says " (node:7744) UnhandledPromiseRejectionWarning: Error: Something took too long to do.

8:32 PM

at timeout.client.setTimeout (/rbd/pnpm-volume/9bdf2605-ab20-4d95-9cea-309850622032/node_modules/

8:32 PM

at Timeout.setTimeout [as _onTimeout] (/rbd/pnpm-volume/9bdf2605-ab20-4d95-9cea-309850622032/node_modules/"

Oh, ok, you’re running it on your own computer! Ok. That makes sense now. I’m not really sure how bat files work, but the usual solution for this problem is just to make sure you have discord.js in your package.json dependencies e.g.

"dependencies": {
       "discord.js": "^5.0.2" //I don't actually know the correct version

Edit: oh, ok, that error you posted does mean you’ve been ratelimited - please post your project name in the topic I linked, or if you’re self hosting you’ll need to change your ip somehow.

Dont work,but thank you anyway,I will send mail to developers :slight_smile:

Sorry, I didn’t see the second post, I edited mine ^^^

I posted,now wait,thanks mate,hope its work again :slight_smile:

1 Like