My project is broken


#1

Here’s my project: https://glitch.com/edit/#!/windows95

There seems to be an error building the project, but I can’t make heads or tails of it. Here’s the latest log message:

TypeError: Cannot read property 'process' of undefined
at Object.logMessage (/etc/service/watcher/source/log-server.js:46:38)
at /etc/service/watcher/source/watcher.js:40:27
at propagateAslWrapper (/etc/shared/node_modules/.registry.npmjs.org/async-listener/0.6.8/node_modules/async-listener/index.js:478:23)
at /etc/shared/node_modules/.registry.npmjs.org/async-listener/0.6.8/node_modules/async-listener/index.js:515:70
at <anonymous>

I would appreciate any help!


#2

Thanks for the report!

We’re deploying a fix right now, should be back online in a moment.

In the meantime a workaround is to trigger a restart of the project-- so, make a change to your package.json file and things should restart and come back to life.

The deploy is complete, things should be fixed now.


#3

Thank you for resolving this so quickly!! :smiley:


#4

@jude

Sorry for the alert, my project just crashed again. This time it’s repeating this message:

npm WARN tar ENOSPC: no space left on device, write

Then my project server is timing out with “504 Gateway Time-out”.

I also tried to make a change to package.json by removing a dependency I wasn’t using, but that didn’t seem to help.


#5

OK, I fixed it by bumping a version number in package.json. Why would it fail intermittently? Is it something I’m doing wrong?


#6

Hi :slight_smile:

so, two things:

  1. the previous error you saw was a bug on our end that we fixed

  2. this other error is caused by your disk being full, it’s a separate issue. The best way to solve it is to enable pnpm for your project, because this way the packages you install won’t take space in the project disk. To enable it, go in the Console (Logs > Console) and run the following command:

enable-pnpm

This should give you a lot of free space. To check:

df -h /app

Let me know if this fixes your issue :slight_smile:


#7

It definitely seemed to cut down on disk space (78% usage down to 23%). Crossing my fingers!