My website is never starting

I have built an express application and when I try to access it directly (With my url and the get(‘/’) function), it’s in “Starting” indefinitely. But the express server can receive requests and answer them without any problem. But, when I replace my code with the default code, the Fastify server, I can access to the website normally.

image

Make sure you’re listening on the right port (glitch uses port 3000)

I’m listening on the port 1988 and with fetch requests that works. This is just when I’m trying to access the website, the default website doesn’t need port in the url to work and when I try to access my website with the url + :1988 it loads indefinitely without even trying to start it.

glitch only exposes port 3000 so you’ll need to listen on that port.

4 Likes

Oh yes it works, thanks.You can receive requests with any port, so I thought you could use any port.

(btw you might want to mark this issue as solved by clicking the “Solved :ballot_box_with_check:” button below) :slight_smile:

1 Like