New > Import from GitHub > forever "Importing" (11ty)

Hi, first time user. The repo I’m using: GitHub - moody-person/11ty-starter: 11ty starter.
Have tried this three times, 20 minute waits, doesn’t finish. Thanks for any help.

1 Like

Hi @Jake_0!

I’m managing to import this ok just now (using the .git url):

https://github.com/moody-person/11ty-starter.git

Could you confirm whether it’s working for you or if you’re still having issues?

p.s. You can just remix my import of the repo if that’s easier :slightly_smiling_face:

Hi @sue-smith , interesting that it works for you. I tried again today but still does not work.

Also, remixing your project doesn’t seem to load either on my end:

Oh no! Are you able to remix anything? For example if you log in, hit the New project button, and choose an option?

it appears new projects will not load either. I clicked New > New Website :

I am using Macbook + Chrome v99.

it could be a problem with your internet. if it isn’t, try making a new account and try from there.
It could also be a problem with glitch.

Is it possible you’re accessing the site from behind a firewall? If so that could be blocking it.

Fort the record, I was able to create new projects via the ui initially, but then I was unable to. Only 1/1000 hours used.
I deleted my account then re-signed up. I am able to successfully create new projects and import from GitHub. Good that it works but it’s concerning that I had to delete my account to fix the issue. Thanks.

Ah that is strange, I’ll pass this back to the team for info. Glad it’s working for you now!

I am experiencing this too. I have used the .git URL, but it just gets start saying it is importing. A new project appears with a random name, but no files.

I am on Windows 10 and Firefox.

Hi @F2Chem it could be down to the project you’re trying to import, if you’re happy to share the GitHub URL here we can take a look!

Sorry to reply so late, but Easter…

If you could take a look, that would be great. It is here:
https://github.com/F2Chem/f2web

It is a pretty simple Node.js project that is currently hosted on Amazon, but I am finding AWS way too complex when something is not quite right, so I am looking for an alternative.

I’m getting a 404 when I visit that url - is it maybe a private repo?

Oops! I have made it public, so should be visible now,

OK so I tried importing and it got partway through then ran out of space so I’d guess that’s the issue, more info here:

If the project hangs on importing, you can try refreshing to see if you can get the editor to load, that worked for me with this project.

I’ve had this same experience. Signing off and back in actually helped solve my issues.

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.