`New Project` -> `Clone from Git Repo` not working

#1

The New Project -> Clone from Git Repo feature doesn’t seem to work.

I tried cloning one of my own projects as well, but that just stopped loading after a minute and created an entirely empty project instead.

If I try to clone create-react-app from their Github repo, it just hangs on the “Fetching Project…” screen forever: try it yourself.

1 Like

#2

Hi @Domiii, welcome to the Glitch forum!

There are a number of situations that can be problematic for the Clone from Repo feature. I can reproduce your issue with the React repo you mention and I’ll take a look to see if I can figure out what’s going on with that one. If you care to provide your other repo name I can take a look to see what’s up with that one (which may be completely different than what’s up with the React repo).

In the meantime, you should be able to use the Import from GitHub option to import the React repo.

Hope this helps!

1 Like

#4

@cori,
I think the repo he/she is using is https://github.com/facebook/create-react-app.git

0 Likes

#5

I was asking after this one:

0 Likes

#6

Hi @cori!
Thank you so much for your fast reply!

Importing from github works fine - that’s awesome!

However, here is some feedback: The importing goes wrong without telling you why if you don’t match the weird (and unconventional) url conversion. The first time I did not add a colon “:” and instead added a trailing slash “/”, and it just failed without telling me why.

If you want to test some more, here is the repository that just produced an empty project after choosing to “Clone from git repo”: https://github.com/Domiii/learn-learn

1 Like

#7

Hey @Domiii, I’m glad the import worked for you and thanks for the feedback. You wouldn’t happen to recall precisely what url you used that failed, would you? When you say

I think) you’re talking about the :path portion of the URL; do I have that correct?

We have some work on the overall Git process planned for the future, and better error handling will probably be part of that work.

1 Like