No space left on device, write pls help

#1

what should I do?

#2

Hello welcome to Glitch

here are some related issues that you could take a look at

https://support.glitch.com/t/storage-warning/9434/8


https://support.glitch.com/t/my-disk-is-full/9263/12

#3

Also try adding more details to the error in words rather than images. To be frank you haven’t said anything

#4

It didn’t work…

I started making mistakes like in the photos while working smoothly.

#5

have you solved the problem?

#6

No, i tried but it didn’t work

#7

Can you share the project link or name so i can take a look if you don’t mind

#8

same problem

Project name : fox-panel

@cori

#9

your project is private i can’t see it.

If @cori said he will fix it then he will i trust his potentials. Just be patient

#10

Hey @egolugur yeah it looks like it’s in the same spot. I think it may be somewhat related to the number of packages you’re depending on; I think your install process is taking enough time that it runs into an issue in how we process the package storage during installation more often than is typical. I’ve made a Remix of your project so we can take a closer look, but in the meantime I’ve taken the same action I did last time and your project’s packages should be properly installed now.

It might be worth it for you to take a look at addressing some of the WARNings you get during install. Getting rid of non-existant packages like cuteapi, for example. I don’t know that it would help with this issue in the future, but it certainly can’t hurt, and it might help if those WARNings are taking up install time.

Also while I was in there I saw this error message:

(node:1441) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 message listeners added. Use emitter.setMaxListeners() to increase limit

This typically means that you’re attaching listeners using .on() event handlers in multiple places, instead of in one central place. It might be worth some time to review where you’re attaching event handlers and making sure you’re doing that in the most efficient way.

#11

Same problem again… How can I always prevent the same problem happening and again help pls uh…

#12

I think I found, i deleted WARN packages

2 Likes