Node.js v14 support, when?

They just turned v14 to LTS. Reference

Yes.
It would be good.

1 Like

yes , we need node 14.x

How about v15? With PHP support? @riversiderocks

2 Likes

you have my vote

The staff don’t really add much to the containers so don’t get your hopes up

Sometime, That version is Unstable.
So better using Node v12.

Hi there - We’re aware we’re behind on Node updates and are working on a plan to update (and stay updated) soon!

13 Likes

Would you guys be able to update other languages?

2 Likes

Yeah especially lanp-poc, it shows server logs.

PHP 7.0.3 is EOL. Upgrading to PHP 8 or PHP 7.4 wouldn’t be a bad idea (PHP 8 is set to release in a week)

10 Likes

We don’t have plans to update PHP as far as I know, no.

4 Likes

Any further news on that? I’m really looking forward to rewrite the code to support the newest Node v14/15 features.

1 Like

Some of my projects have 12.20.0 and 14.15.1 installed today, but pnpm is broken on 14.15.1, forcing me to use npm, also, I can’t seem to use 12.20.0, but strange enough, new projects does the new versions, also, nodeversions.glitch.me is reporting that it has 12.20.0 and 14.15.1, so I think it’s not fully deployed/supported

EDIT: It’s actually random, I tried remixing and now I got 14.x, but 12.x still resolve to 12.0.0

1 Like

I kept getting this error when I tried changing to Node v14:

node v14.15.1, with pnpm
Installing...
/opt/nvm/versions/node/v10.15.3/lib/node_modules/pnpm/lib/node_modules/graceful-fs/polyfills.js:285

if (cb) cb.apply(this, arguments)

^

TypeError: cb.apply is not a function
at /opt/nvm/versions/node/v10.15.3/lib/node_modules/pnpm/lib/node_modules/graceful-fs/polyfills.js:285:20
at /opt/nvm/versions/node/v10.15.3/lib/node_modules/pnpm/lib/node_modules/graceful-fs/polyfills.js:285:20

at FSReqCallback.oncomplete (fs.js:184:5)

Note: I also tried removing my dependencies, executed rm -rf node_modules and refresh.

Hi there - the containers don’t have v14 installed on them yet, hence the errors, but upgrading is something we’re actively working on.

3 Likes

Yes, that’s the pnpm problem I mentioned in the last reply, node v14 broke pnpm v2

Do you also have a plan to update pnpm to v5?

1 Like

 

3 Likes