Node keeps printing "Resolving: total [...], reused [...], downloaded [...]" Won't start up


#1

Hi! A few minutes ago my bot went offline and when I went to see what was wrong I saw it kept printing this:

node v8.12.0, with pnpm

10:46 AM

Installing…

10:46 AM

Resolving: total 5, reused 0, downloaded 0

10:46 AM

Resolving: total 10, reused 3, downloaded 0

10:46 AM

Resolving: total 58, reused 9, downloaded 0

10:46 AM

Resolving: total 58, reused 12, downloaded 0

10:46 AM

Resolving: total 64, reused 52, downloaded 0

10:46 AM

Resolving: total 65, reused 57, downloaded 0

10:46 AM

Resolving: total 71, reused 64, downloaded 0

10:46 AM

Resolving: total 102, reused 70, downloaded 0

10:46 AM

Resolving: total 107, reused 99, downloaded 0

10:46 AM

Resolving: total 146, reused 104, downloaded 0

10:46 AM

Resolving: total 146, reused 104, downloaded 0

10:46 AM

Resolving: total 146, reused 142, downloaded 0

10:46 AM

Resolving: total 159, reused 144, downloaded 0

10:46 AM

Resolving: total 181, reused 160, downloaded 0

10:46 AM

Resolving: total 183, reused 177, downloaded 0

10:46 AM

WARN discord.js@11.4.2 requires a peer of bufferutil@^3.0.3 but none was installed.

10:46 AM

WARN discord.js@11.4.2 requires a peer of erlpack@discordapp/erlpack but none was installed.

10:46 AM

WARN discord.js@11.4.2 requires a peer of libsodium-wrappers@^0.7.3 but none was installed.

10:46 AM

WARN discord.js@11.4.2 requires a peer of node-opus@^0.2.7 but none was installed.

10:46 AM

WARN discord.js@11.4.2 requires a peer of opusscript@^0.0.6 but none was installed.

10:46 AM

WARN discord.js@11.4.2 requires a peer of sodium@^2.0.3 but none was installed.

10:46 AM

WARN discord.js@11.4.2 requires a peer of uws@^9.14.0 but none was installed.

10:46 AM

WARN enmap@4.3.3 requires a peer of better-sqlite-pool@^0.1.2 but none was installed.

10:46 AM

Resolving: total 185, reused 177, downloaded 0

10:46 AM

Resolving: total 185, reused 181, downloaded 0

10:46 AM

Resolving: total 185, reused 181, downloaded 0

10:46 AM

Resolving: total 185, reused 181, downloaded 0

10:46 AM

Resolving: total 185, reused 181, downloaded 0

10:46 AM

Resolving: total 185, reused 181, downloaded 0

I ran rm -rf .git as well as git gc and git prune. I also checked the disk space and it seems like I have enough.
What should I do now?


#2

It’s installing the modules your project uses, which is normal and you just need to let it finish. If the process still hasn’t completed then let us know the project name and we’ll take a look.


#3

Yesterday I had no problems with my project at all. and suddenly I get this:
https://hastebin.com/ifidipanoq.makefile


#4

You likely have a problem with the node and/or module versions you’re using. Let us know the project name and we’ll take a look.


#5

Dragonbot
Need to have 20 chars lol xD


#6

Found anything yet? I see someone is in my project


#7

The problem resolved itself.


#8

I upgraded Node, and it seems happy now!