Node v8.15.1, with pnpm installations bug

A few days ago my project started installing a new node version (8.15), then I noticed that this update started to install every 30 minutes approximately and that update takes too long to install and makes my project inactive for a long time for blame that that is installed every moment. Is there a solution for that ?, it still happens to me

Lemme say…
pnpm >>>> npm

the recent issues have destroyed our node packages and pnpm now takes forever to install

2 Likes

ahh thats true though. It took me a whole hour to finish a pnpm installation that resulted with a “bindings file” error and I had to install again :neutral_face:

yep, mine just takes forever installing node-gyp binaries…

2 Likes

Is there a solution for that? Or will I have to do my project from the beginning again?

Unless you know how to stop your project automatically downloading your node modules. Your stuck

same what the hell going on gltich ???

It’s an issue, which @glitch_support needs to fix…

Sigh… I’m leaving this conversation because there is nothing I can do.

Same for me, they should fix it soon

@glitch_supportPlease fix that

@glitch_support fix that x2

I managed to fix it with sheer persistence by removing node modules, waiting, using npm, waiting, remove node modules again, waiting etc. I’m gonna use my vps as a pinging service until I can move everything from glitch to my host. Such a shame since I was about to purchase glitch premium, but the issues such as no PayPal, broken CloudFlare SSL (broken domain linking) and other small issues have made glitch too unstable which is also causing a huge loss of profit as the payment site is not accessible.

@glitch_support fix this finally. How much longer do we need to wait?

Nevermind it came back :joy: :sob:

Got it fixed again, I don’t know if this will last but I did:

  • rm -rf node_modules

  • Changed node version in package.json to 10.x

  • Forced package reinstall by editing watch.json

  • Waited 20-30 minutes

  • Works now

  • I also set up a 4 minute pinger from my vps

Are you sure you fixed it?

I guess, try with reinstalling your packages by typing npm rebuild in your terminal.

I cant imagine this will solve anything,

I deleted the whole node_modules folder already many times I did other crazy stuff going back with node version to 10 and 8 and back to 10 and many many other things. It is jsut Glitch being unstable for whatever reason suddenly

It appears to be fixed, only thing affecting me now is projects not starting/slow.