Nodejs Discord project any way to save disk space?

Hello I am working on this repo and want to deploy it on glitch but am running out of disk space.

I also deleted the devDependencies so they are not install at pnpm i

Here are my steps in deployment:

  1. install nvm to get node.js
  2. install pnpm
  3. pnpm i //I am stuck here as I run out of space with my dependencies ;(
  4. pnpm prune
  5. pnpm start

Is there anyway other way I can save space to fit my discord project? Otherwise I will have to use another service.

my glitch project name is free-daily-sawfish for reference

Can you try running this in the Glitch terminal:

du -h -d1

It should reveal any large folders, i.e.
image

1 Like

removed nvm since I only needed it for install. Anything else I can remove?

Also seems like every time I open glitch the node version is downgraded to v12.0.x and yarn stops working so I have to reconfigure… How exactly does glitch work?

1 Like

Hey, have you got a Node version specified in your package.json under engines? like:

  "engines": {
    "node": "14.x"
  },

ahh thanks, just added that. I did enable-pnpmand want to update but I get this:

i tried installing via pnpm but I am getting this error


.
cant seem to install gloabally? but just npm i yarn works. why is this happening?

Screen Shot 2021-06-19 at 6.50.33 PM

what is the os running the glitch servers? I cannot get sudo access to update node… ;(

changed the yarn and node version req in engine to be 1.x and 14.x respectively in adherence to Can I change the version of node.js my project uses? - Glitch Support and things are installing~!

but now I’m having this issue:

huh re ran and it worked

messed around and things seem to work

2 Likes

Nice solve :+1: Well done for doing the legwork.

You can’t use sudo on Glitch containers because they’re locked down for security, and this is also the reason you can’t globally install packages (it internally requires sudo).

2 Likes