Not uploading GLB file

Hello,

For the last 4 days i am unable to upload glb files to my 3D VR project. I have tried with .jpg and .png and i have no issues, only with glb.
My project https://roberto-hd.glitch.me
Can someone have a look please?

Thanks

Hi @joaoibsilva

I’m sorry that you are having trouble adding new .glb files to your project! So we can get a better idea of what’s going on, can you let us know the following?

  1. What is the size of the .glb file(s) that you are trying to upload?
  2. Where are you trying to upload the files from?

The maximum size is 25MB but in the past i have uploaded files as big as almost 100MB!
Files are being uploaded from my laptop.

Thanks

Thanks for that info. If you are uploading them from your laptop, then that shouldn’t be causing the issue. However, I do think that the file size may be causing the problem (even if uploading files above the limit has worked for you in the past.)

Here are two things you could try to confirm it is a size issue:

  1. Do you have a smaller .glb file that you can try to upload to compare what happens?
  2. What happens if you temporarily delete one of your larger .glb files that has already been uploaded to your project, and then you try uploading the new one that is giving you difficulty?

Also, if you have already tried this let us know so we can troubleshoot further.

Hi,

I have tried a new project and it seems like the issue is that the file loader is not visible anymore and most of the times gives me a loading error.

Thanks for the update @joaoibsilva. I’m sorry that you are still not able to get it to work!

Are you saying that the Upload an Asset button is not displaying at the top of the editor page when you go into assets? If so, can you tell me the name of the project where the button is not showing?

Hi @tasha
The upload an Asset Button is visible and it is there but when you select the Asset to upload no loading bar that shows the progresso becomes active and the upload fails, if you do it via drag and drop no visible action also and the outcome is the same.

Thanks for the clarification!

What is the size of the file?

The Project is roberto-hd.glitch.me and the file size is around 25MB but like i said i have uploaded in the past files 3x more than that, unless if something changed that i am not aware of.

OK thanks! Our team did some additional investigating.

We think the issue may be that the combination of the files you have uploaded and the files you have deleted has overloaded things, without telling you. Our team will put this in our queue to address.

In the meantime, you should be able to overcome this by making a new working copy of your project using the remix feature and giving the project a new name. That way you can leave the cdn baggage thats holding you down behind!

Let me know if that works for you!

Ok @tasha here is the last and final update. Mixing the project and renaming it does not solve the issue. Creating a new Project inside the same account does not work either. I decided to go back to an old account which i barely used and also the same issue. Ok here is the conclusion. If i upload an image file as big as 4MB the progress bar shows the upload progress. If i upload a .glb file smaller than the image file it does upload but no progress bar is shown. If i upload a .glb file bigger than 10MB no progress bar is shown and the upload fails. I think i have tried all the possibilities unfortunatelly i need to test a project and i will most certainly look for another option with much regreat as i really like Glitch.