OAuth Login Problem


#1

Hey Glitch Team,

I’m not able to sign into Glitch using GitHub on my account (patrickweaver on both Glitch and Github). Getting the errors shown below at the urls below. I get the same errors whether or not I’m signed into GitHub beforehand or not (though I sometimes get the “Authorize Fog Creek to . . .” prompt (not sure exactly when).

From glitch.com:
https://glitch.com/login/github?code=80f59 . . . (random string)

02%20PM

From Editor:
https://glitch.com/edit/?code=f744c6 . . . (random string) . . 41#!/?code=f744c6 . . . (same random string) . . . 41

14%20PM

I am able to login to Glitch using a different Github (and different Glitch) account (mousefridge on Glitch/Github). Strangely, I’m not able to login to Glitch (same error) using a mousefridge Facebook account (though I’m not sure it was ever connected – or if connecting both facebook and github is possible). I am able to login using a different Facebook account, but it created a new Glitch account.

Tried in Chrome, Safari, Firefox on two different computers with different versions of OSX.

I’m still able to access my account on a third computer that I was already signed in to.

Thanks!


#2

Hello!

sorry for the issue :frowning: We are investigating. Can you please try to login again, so we can see the error?

Please let us know when you tried.

Can you also try to log in from an anonymous/guest window?


#3

For anyone else that encounters this problem, the issue was that I have 2 Glitch accounts, and I moved the email from the GitHub account on the first Glitch account to the GitHub account on the second Glitch account (personal/work email addresses).

The solution was removing the email address that was connected to both Glitch accounts from my GitHub account I was trying to use to log in.