Ongoing project instability and page not found / 404 issues

Hey y’all we’ve still been seeing some intermittent problems on a few projects exhibiting behaviors like

  1. Seemingly random pages returning 404 / page missing problems
  2. Entire projects showing Not Found results
  3. Console not responding (showing “transport error” or “Reconnect”

I’m going to collect all the reports that seem related to this behavior under this topic so we have a single clearing house for them.

Project Not Found Writes When I Enter Glitch Site
under Maybe a typo? Or maybe it’s been renamed? write pleas help me

1 Like

Me2 Procject not found when i join to glitch website
and cant continue codeing on my project :3

Check status.glitch.com - there is major outage in Glitch’s projects containers system and API

image
is it down or something?

1 Like

Click me

Thanks! I should have checked the status.

My project at https://dailyworkout.glitch.me has been working perfectly, until this morning.
Sometimes the page loads, and other times it does not, and if I look at the developer console I am getting 404 errors, but for different files each time.
I don’t see why this would be an issue with my code, so is this an issue with Glitch?
Also, I am being bombarded with emails from UptimeRobot each time that service encounters a 404.404

Just looked into this further, and Chrome seems to be showing the source for Glitch’s project not found page instead of manifest.json. Like I said, if I refresh the page sometimes its fine, but others its not.

So I had my typical round of ‘modules not found’ that can be fixed by running pnpm i. However when I tried opening both full console and the log console they did not load. Project strawbot

I remixed my project and the console started working

1 Like

I had a similar issue after the outage this morning as well. Seems like something must still be corrupted after Glitch came back up earlier, but I don’t know enough about their back-end to even guess at what.

Remixing also resolved the issue for me (though I had to juggle project names afterwards for a sec to get the remixed copy back to the original name). The copy that went down seems to still have the issue, though it’s not actually in use anymore.

I can see and load the console
And i got transport error

im having the same error, i think the glitch staff must not be in office right now.

I was having this issue, and, as mentioned in this post, remixing seems to fix it (on the new copy). Otherwise we’ll have to wait for the glitch team to find and correct whatever this is, as it sounds like it is happening to quite a few projects.

I cant quite remix my project since it requires the use of the data on the .data/ file

When ever i try to access the console of my project I get the 404 page then i refresh and i can an error
Error: transport error then i wait and then the console comes up.

Thats the console error ^
But if i go to https://mythical-bots.glitch.me/ the page shows the starting up page then comes online, even though my project is online and working. I think this has to do with the issues this morning.

Hey @HunterWilson56 I’m seeing some odd behavior on this project’s console as well. I don’t have a full solution for you, but it seems as though Remixing the project resolves the issue, so you might give that a try. Sorry for the bother!

quite a few projects are still broken

1 Like

Hi @Matthew-MK sorry for the bother if you’re still experiencing problems; can you provide any details of project names and in what way they’re broken?