/opt/watcher/app-types/node/install.sh: line 106: ((: <= 11: syntax error: operand expected (error token is "<= 11")

Huh… I’m not sure why but my project doesn’t work.

Error: Cannot find module ‘express’
Weird, because express is in my package.json file and everything worked fine for months.
Tried to npm i but I have error access and internal errors :

No Node version was specified; we are using default version 10. You can change this in package.json: https://glitch.happyfox.com/kb/article/59-can-i-change-the-version-of-node-js-my-project-uses/

8:34 AM

/opt/watcher/app-types/node/install.sh: line 106: ((: <= 11: syntax error: operand expected (error token is "<= 11")

8:34 AM

node v10.23.0, npm 6.14.8

8:35 AM

Installing...

8:35 AM

npm ERR! code EACCES

8:35 AM

npm ERR! syscall open

8:35 AM

npm ERR! path /app/node_modules/formidable/npm-shrinkwrap.json

8:35 AM

npm ERR! errno -13

8:35 AM

npm ERR! Error: EACCES: permission denied, open '/app/node_modules/formidable/npm-shrinkwrap.json'

8:35 AM

npm ERR! { [Error: EACCES: permission denied, open '/app/node_modules/formidable/npm-shrinkwrap.json']

8:35 AM

npm ERR! cause:

8:35 AM

npm ERR! { Error: EACCES: permission denied, open '/app/node_modules/formidable/npm-shrinkwrap.json'

8:35 AM

npm ERR! errno: -13,

8:35 AM

npm ERR! code: 'EACCES',

8:35 AM

npm ERR! syscall: 'open',

8:35 AM

npm ERR! path: '/app/node_modules/formidable/npm-shrinkwrap.json' },

8:35 AM

npm ERR! isOperational: true,

8:35 AM

npm ERR! stack:

8:35 AM

npm ERR! 'Error: EACCES: permission denied, open \'/app/node_modules/formidable/npm-shrinkwrap.json\'',

8:35 AM

npm ERR! errno: -13,

8:35 AM

npm ERR! code: 'EACCES',

8:35 AM

npm ERR! syscall: 'open',

8:35 AM

npm ERR! path: '/app/node_modules/formidable/npm-shrinkwrap.json',

8:35 AM

npm ERR! parent: 'app' }

8:35 AM

npm ERR!

8:35 AM

npm ERR! The operation was rejected by your operating system.

8:35 AM

npm ERR! It is likely you do not have the permissions to access this file as the current user

8:35 AM

npm ERR!

8:35 AM

npm ERR! If you believe this might be a permissions issue, please double-check the

8:35 AM

npm ERR! permissions of the file and its containing directories, or try running

8:35 AM

npm ERR! the command again as root/Administrator.

8:35 AM

8:35 AM

npm ERR! A complete log of this run can be found in:

8:35 AM

npm ERR! /tmp/npm-cache/10.23.0/_logs/2020-12-21T07_35_18_931Z-debug.log

All good. Updated the Node Version in package.json
=> enable-npm in Terminal

  "engines": {
        "node": ">=12"
      },
2 Likes