/opt/watcher/app-types/node/start.sh: line 51: nodemon: command not found

Hello, please help, this project is not loading and it is part of my thesis. Please help, I worked a lot on my degree project and I almost have to hand it in and this is essential.

The Log says you have this error: /opt/watcher/app-types/node/start.sh: line 51: nodemon: command not found

This is my package.son:
“name”: “prueba-imgs”,
“version”: “1.0.0”,
“description”: “”,
“main”: “index.js”,
“scripts”: {
“start”: “nodemon servidor.js”
“author”: “”,
“license”: “ISC”,
“dependencies”: {
“express”: “^4.18.2”,
“multer”: “^1.4.4”,
“nodemon”: “^2.0.22”,
“node”: “^20.2.0”,
“nps”: “^5.10.0”,
“npm”: “^9.6.7”,
“is-npm”: “^6.0.0”,
“npm-run-all”: “^4.1.5”,
“npx”: “^10.2.2”,
“dev-null”: “^0.1.1”,
“react-codemod-empty-node-to-null”: “^1.0.1”,
“adal-node-null-cache”: “^1.0.0”,
“null-register”: “^0.1.0”,
“node-buffertrim”: “^1.0.0”



And this is my project: Frijolmagicorecetas

Please :frowning:

I’ve heard about problems adding this on Glitch. not sure if the problem with it results in the exact message you are seeing though.

I understand, thank you, so what do you suggest?

would you be able to port your app to node.js 16 or earlier?

1 Like

Yes, that would probably work. The project seems down, have you archived it?

I do not understand :(, I used a template on this project because i am new with this and the template was ok, but today it is not working anymore :frowning:

noo, it is public, the website was working yesterday but today it does not load. The only thing that always happened with this website is that at the beginning there was a warning that the inactive projects were going to sleep, and it took a long time to open, but it opened and this time it stays like that forever or it doesn’t even load.

meaning that it worked locally? or did it even work on Glitch?

i do not reply :p: worked on any computer where it was opened through the glitch page, i.e. whenever I opened this page it always worked: https://frijolmagicorecetas.glitch.me/

can I see the working template?

Is this one: Glitch :・゚✧ and it isnot working :(. I do not know what to do.

I want to try this what should I do? To install node 16

use the method from this article to set the node.js version


OMGGGGGGGGG, you saved my lifeeeee, it is working. I love you so much, god bless you.

Look it is working https://frijolmagicorecetas.glitch.me/

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.