Package.json error

Hello, I have been using a NPM package called enmap for awhile now on numerous projects but today all of the projects with it installed don’t start due to this error (see image) I have tried to reinstall the package but that doesn’t fix it.

Hi @Crypto

I’m sorry that your projects are suddenly showing this error! This is a bug that occasionally pops up which prevents the project editor from fully syncing with the container that the project is currently on. Our team is working on fixing this.

In the meantime, if you see an error like this suddenly in your project and your project is using Node version 12 or older, here is how to fix it:

  1. Open the project terminal
  2. In the project terminal run the command: enable-pnpm

If that does not help, or if your project uses a newer version of Node, please send us a support request so that we can help you further.

1 Like