Package.json freezing the editor

If I try to access my package.json file on my project bongo-bot all my devices freeze or crash. Help!!

EDIT: It seems like the debugger checks the file before opening it or something and then causes it to hang.
EDIT 2: If you’re still having a problem either export the project and look for the red error marks on your package.json OR use ‘nano package.json’ and try to self-debug the file looking for dumb mistakes like a comma after the last dependency.

1 Like

Could you post a link for your project so we can help?

I can reproduce, if I access my project it goes to package.json and crashes :eyes:

EDIT: Seems unfixable unless higher ups repair the container.

you can just look it up but here’s the link: https://glitch.com/~bongo-bot

The link is broken can you post another link?

Privato. But it seems to be an issue as I have the same

i made it public now if you want to retry the link

Actually nevermind just doing ‘’‘npm install’’’ fixed it

Hmm might be my issue too as I used the wrong installer by installing a package using the npm module

Edit: Uh multiple projects are starting to do this now

Try removing these
"engines": {
“node”: “8”
},

Sooo uhm

I cannot even edit it

Try putting this
"version: "0.0.1"
Instead of
"version" '

As I said it crashes when accessing package.json

DM Me with a join invite so i can see where is the problem

Hey @Sem1084 I’m not encountering this when I access https://glitch.com/edit/#!/bongo-bot?path=package.json:1:0, on my laptop or iPhone. Are you still seeing this issue?

My project is called readthedocs, but I am experience this on my 3 latests projects

I also have this problem in one of my projects… Tried every browser i had and i could not get it fixed.

Try creating a new one, before opening any others

Oh, sorry about that, @Sem1084; I misread the thread.

I can reproduce this on ~readthedocs, but not on @rhld13’s ~bongo-bot.

@AXRAY23, welcome to the Glitch forum, and sorry for the bother. Can you give us some example projects you’re seeing this on?

Also (although I’m doubtful this is the issue) can everyone who’s seeing this let us know what browser, operating system (and device model, if appropriate) you’re seeing this on?

I am having this with my project “bewnce2” now, whenever I open the package.json, the whole window becomes unresponsive. I have to put ?path=server.js:24:0 after the link, to open the project without it going straight into package.json.

Running the latest version of chrome - stable
On windows 10 - Medion Akoya