Page of my website is not working

When I visit, it takes a very long time to load and when I does load, I get redirected to (which never loads because it is on port 3000). Is there any way I could fix this?


That page isn’t loading for me either. We’ll take a look!

This looks like it is the Apache web server doing something strange. When I request that URL not with a browser, I get:

$ curl

<title>301 Moved Permanently</title>
<h1>Moved Permanently</h1>
<p>The document has moved <a href="">here</a>.</p>
<address>Apache/2.4.18 (Ubuntu) Server at Port 3000</address>

The browser respects the 301 redirect and tries to go to that address, which I think Apache might have gotten from inspecting the environment assuming that’s how it was exposed externally (it is listening on 3000, that’s just not how you get to it from the outside).

Maybe see if there’s a way to explicitly configure the public host and port for the way you have Apache set up.

1 Like

without the port it works

Here is what I tried:
In .htaccess I set the listening port to 443 and 3000. (this is my full .htaccess file and I choose 443 because works)

ErrorDocument 404 /404.php
ErrorDocument 403 /403.php

Listen 443
<VirtualHost *: 443>

RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^([^\.]+)$ $1.php [NC,L]

This gave me a 500 error on / and still did the endless loading loop on /software. I tried redirecting the software page to the home page but that did work either. The server seems to think the website is which seems to be a mirror of my glitch project. Any other ideas?

This is the code on the software page, if it helps. <—
This is my project (private because of API keys, if you need to use an admin account I am fine with that)!/riv3rsid3


After some more research, I believe that you would need to access Apache configuration files to change the port. That or you would need sudo access… Would any of these be possible in glitch?

Odd, this seems to be happening again.

It works for me @RiversideRocks

What page did you visit?
This is the broken page:

Oh. I visited My mistake. That page doesn’t load at all!