Permission denied for exec command

discord
#1

I’m trying to host a discord bot, over glitch, and I have successfully installed the bot on glitch, but the bot is off by automation, and if i try to launch the bot from the Glitch Console.

I tried writing refresh in console, and writing command again. Still didn’t work.

My console when i write command:

$ exec ./bot.js
-su: /app/bot.js: Permission denied
-su: exec: /app/bot.js: cannot execute: Permission denied

#2

Hey @darknessgamingdk, welcome to the forums!

Are you able to run bot.js without using the exec command? maybe by running node bot.js instead?

#3

Hey and thanks.

If i use exec command, i get the error i posted above. Maybe i wasn’t clear enough.

If i use node bot.js i get
Sk%C3%A6rmbillede%20(364)

#4

Do you have discord.js package installed?

You can do so using:
npm i discord.js —save

#5

I don’t think i do.

And when i do npm i discord.js --save i get a new error. Might be because i don’t know how to make that line you did, and i can’t copy paste it.
Sk%C3%A6rmbillede%20(365)

#6

So i got discord.js installed, but i stil can’t launch my bot. I get this error in my Logs:

" /opt/watcher/app-types/node/start.sh: line 49: null: command not found "

#7

@darknessgamingdk

Can you invite me to your project!

#8

Can you contact me in PM somehow. It seems i’m not allowed to post link here.

#9

@Callum-OKane and @darknessgamingdk did you all sort this out?

#10

Nope. He got access to my project, then never said anything.

#11

https://discord.gg/NRbAdcc I can help if u pm here

1 Like
#12

Sorry @darknessgamingdk,

I had not responded because I had to bring my mother to the hospital in a rush. Right now, I see no errors, but for some reason the bot is not starting, but all errors are gone from what I can see, is there anything I am missing?

#13

I managed to fix everything now. I don’t know what the problem was. I just reinstalled the whole bot, and slowly kept an eye on if it was working the whole time, and that fixed it somehow.

1 Like