Please add nodejs latest versions

Hello, it’s almost one year and we’re still stuck on node version 12.0.0? node version v15 released on 2020-10-20, and v14 becomes LTS on 2020-10-27, and node version 12.19.1 is out on 16th of November, yet we don’t have the latest version of nodejs, what’s blocking glitch to update node? also, nodejs v12 will becomes maintenance by the end of the month. If we can’t update to v14, please update nodejs to the latest v12 version, there are lots of security fixes and new features, for example, ES2020, I need Intl.DateTimeFormat with { dateStyle: "short", timeStyle: "medium", hour12: false } as an option which is not supported by node version 12.0.0, but it is supported on 12.9.0 (Reference)

5 Likes

I’d like to know the ETA though

ETA is unknown, I’ll post here once the Node version gets upgraded.

2 Likes

Bookmarked.

2 Likes

Node v12.20.0 and v15.3.0 just released 10-11 hours ago

@tasha Can you merge this with the other post?

3 Likes

I think glitch has 12.x meaning, all v12 are installed

No there’s only 12.0.0 in glitch, as you can see in nodeversions.glitch.me

It’s the 30th of November here in Jakarta time, v12 will soon go to Maintenance LTS

1 Like

+1, This is very important, since more nodejs is releasing new versions

1 Like

I suggest you vote here:

Please use this thread from now on, Node.js v14 support, when?.

1 Like