Problem after delete a project

Hi!
This is my first support thing on Glitch, I am sorry if I do/did mistake.
Today I saw a problem. I entered to Glitch homepage to find something (Glitch is the best place to find different creative things) then I found a project nice (Blueridge) Tried and loved it. Remixed to edit longitude, latitude and try something to improve myself on coding. After that, I removed some files by mistake then I wanted to delete the project and remix again. After removing it page was loading forever .Url was deleted projects name so I understood it needs to forward but it forgot. So I manually entered a project name I know and saved myself from that. Because trying to go https://glitch.com/edit/#!/ didn’t work it forwarded to deleted projects url and loaded forever again. (I say forever because it took more than 3 mins.) I am sorry I forgot to save the log on Inspect/Console. Can you fix it Glitch?
Thank you!
Halil

Hey @RisksY, welcome to the Glitch forum!

Sorry you ran into this problem. We have a bug with deleting projects right now where the editor doesn’t properly go to a new project after you click delete:

https://app.clubhouse.io/glitch/story/6042/reconnect-issues-in-editor-when-deleting-a-project

The project in question was moved to your deleted apps, however. We’ll post an update when the problem is fixed. Thanks for reporting it!

1 Like

I tried what did I do again and saw this error by Firefox:

  • Warning: Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://api.segment.io/v1/t. (Reason: CORS request did not succeed).

  • Error: log socket error
    -Error: Firefox can’t establish a connection to the server at wss://api.glitch.com/hash/ot?authorization=hash

I am at Ubuntu 19.10 eoan (I’m not sure about 19.10 can you say how can I check?

The issue related to segment.io it’s common across most browsers. (Most of them block the request). However, the failed request to segment.io shouldn’t cause any issues with the site as I believe it’s just an analytics tool.

@potch, that’s a very frustrating bug, because I can’t know if it’s deleted or not. Here are the logs I’m getting: