Problem importing projects from Github

Hey, I’ve been trying to import a project from Github. When I go to New Project > Import from Github, and enter the URL to the repository, a message comes up in the top right corner saying, “Couldn’t connect to your project. Try refreshing.”

At this point I’ve tried cloning several different repositories but am facing the same issue. Note that all of these repositories are public and created via my own Github account.

Hi there, could you share the url for one of the projects?

1 Like

Hi Sue, I am having this exact same problem myself. I get the described error message when I click “New Project” and “Import from github” and paste in a url. When I reload the project there is a generic readme but no other files. I tried with a few different github projects. You can try it with these urls:

Oh, I solved this after looking at a few other forum posts here. If I clear my browser cache and then log in to glitch, it seems to work. I’m guessing this has to do with the fact that I use Github to log in to Glitch and maybe some wires got crossed.

Ah that’s annoying! Will feed back to the eng team in case we don’t already know about it.