Problem when I install a package

Hey!
When I want to install the package: discord-crasher-detector, I have this:
npm WARN tar ENOSPC: no space left on device, write

4:11 PM

npm ERR! cb() never called!

4:11 PM

4:11 PM

npm ERR! This is an error with npm itself. Please report this error at:

4:11 PM

npm ERR! https://npm.community

4:11 PM

4:11 PM

npm ERR! A complete log of this run can be found in:

4:11 PM

npm ERR! /tmp/npm-cache/14.15.2/_logs/2021-05-23T14_11_45_052Z-debug.log

And when I install other package, works :confused:
And when I install the package with cmd in my pc, works.
So, I think its a problem to glitch, pls help me :confused:

You don’t seem to have any more space. Can you run git gc && git prune?

Done.
But now when I npm i (the package), I have the same error, but if I add other package, works :confused:
Its a package problem or glitch problem?
If you want to test to add the package:npm i discord-crasher-detector (its to check if a video crashs discord)

Can you run this in your console?

cd && du -sh

(git might not be the only thing taking up space)

Done.
Same error.
A friend says I need to rebuild my package, I test at 2pm because I’m in school, I will say you if works or no.

So, I do cd && du -sh
but I have same error, I think its really a problem with the package idk :confused:

And when I do this command, I have: 31M

That’s weird, I you have only used up <25% of the space on your project. The package you want to install might be too big for Glitch. I’ll try it on my VPS in a little bit to see how much space it takes up.

With your vps, works or no?
I tested npm init un my pc with cmd
When I install the package, works but when I npm i quick.db, there is a error, I think quick.db is not compatible with discord-crasher-detector :confused:

I installed it on my vps:

Screenshot 2021-05-26 8.57.20 AM
This package seems to big for Glitch, I’m really sorry about that.

Oh, ok ok :confused: I will buy a vps oof