Problem with Github import


I just wanted to import my project from GitHub, but when I click Import from GitHub it just says Importing from Github but then it says We're sorry, something went wrong. Please try again. Or refresh the editor

I’ve already searched a solution but nothing helped so don’t tell me that I should look at other posts

The screenshot is taken from my smartphone, but I already tried to import it on my PC but I didn’t work there

I would be glad if someone could help me

Screenshot_20200226-213605_Firefox Nightly|225x500

Hi there,

Sorry the import isn’t working. Can you send me the link to the Github repo you’re trying to import, so I can debug?

Thank you!


Please give me a second, I’ll make it public

Thanks a lot for helping

Thanks so much!

I was able to successfully import from Github. Can you give it a try now, and see if you’re able to as well?

This makes me think that the issue with authentication when importing a private repo.

Let me know if you still run into an error while it’s public.

Thanks a lot for the fast assistance

I tried it again to import while it’s public but it gave me the same error again

Can you talk me through what steps you took to import the repo so I can investigate further?

When I tried, I followed these steps at the top of the page. Could you give that a try?

When I signed up to Glitch I connected my GitHub Account

Then I created a new project for my Discord Bot

I clicked on Tools -> Git, Import and Export -> Import from GitHub -> entered the Link (ProfessorVarox/GameTec-Partner) -> OK

Then the issue happened

Thanks for the info @ProfessorVarox!

Inside the Git, Import and Export panel is there a blue box titled Grant us access? If it’s present you’ll need to click that button to fully connect your Github account.

No, there isn’t this button

This is a tricky one. Thanks for sticking with me @ProfessorVarox as we debug this!

Could you click the link that says “Revoke GitHub repo access” in the Git, Import and Export panel? When you do this the Editor will reload. Go back into that same panel, and click the button to Grant access.