Problem with uploading a git repo

discord
#1

When i open a new project and i try to upload my Github Repo, it gives me the following message. image I had this same problem 2 days ago and when i posted something on the forum and i went back to my project it worked. Nothing i tried work.

Greetings,
Epic Minion

#2

Hey @TheEpicMinion- can you open up the logs of the project you’re importing to and see if there’s any more detailed errors?

#3

Hey @potch It only gives me this message. All the times.

#4

What method are you using to upload your github repo?

#5

I make an “Node-express” project and i go to the bottem left corner and click on “Tools” and than “Import from Github”image

#6

Can you try clicking on “Revoke repo access” and then re-enabling it?

#7

@TheEpicMinion What @potch means is if the repo access is off you can’t access through git. And if it’s on and having that error, usally means something went wrong when enabling it.

#8

I did it and it worked…
…But not everything is being uploaded.
Thnx BTW both for your help!! <3

#9

@TheEpicMinion I recommend using the command git fetch https://github.com/user/rep.git

#10

@Infinity1231 Thnx, i tried but even the using the command doesn’t work. It keeps giving me this message.
image
Thnx anyway.

#11

Yes that’s the message you’ll see. If you refresh the page, you’ll see all the files

#12

If you’re going to use the git commands in the console, @Infinity1231, you’ll probably need to follow git fetch with a git merge, or you can use git pull (which is basically a git fetch followed by a git merge). git fetch retrieves the changes from the remote repo, but it doesn’t check them out into your local file system. This StackOverflow answer is a good, short explanation.

If you want to try getting the Glitch Import from GitHub working I’m happy to try to work with you on it - there may be a reasonable explanation of what you’re experiencing, or it’s possible there’s something amiss somewhere. If you’d like to do that then I suggest you perform these steps:

  1. As Potch mentioned, Revoke and Re-grant Glitch access to your GitHub account
  2. Create a new project
  3. Use the Import function and see how it goes.

If all does not go according to plan, let us know what errors you encountered, if any, including any error codes provided, what the project name you’re importing to is, and the value you provided at the import step. Given that information we might be able to sort out what’s going wrong, and at least provide a reason, even if we can’t provide a solution.

#13

Ok. I did as you said. This is what i got.

First i tried if it would work normaly, but it didn’t. :neutral_face:

  1. I Revoke the access to my GitHub account and Re-granted it. This is what i got.

-> I got this message in my logs. image
But if i went to my Project domain page, i did saw PARTS of my project. But if i would refresh my editor page or re-open it, i wouldn’t see the documents i saw on my project domain page.

  1. I did all those things already in a new project so yea…

  2. I first try with a Git pull and it gave me this message. I did also got some counters counting to 100% but they where to many lines up to be loaded. Cause it spammed a bunch of node_modules's
    image

So i made a new project and i tried with a Git fetch and it gave me this message. And i refreshed as @Infinity1231 said.
image

But even if refreshed i still didn’t saw the files. Not in my editor or on my project domain name.


Then i made a new project and did a git fetch and a git merge FETCH_HEAD. And when i did the git fetch it gave me this.
image

And i got the following message when i did the Git merge FETCH_HEAD
image

And still i didn’t got anything in my editor screen or in my Project domain page.

So yea thats all what you said @cori. I hope you have all the information you needed.
BTW thanks to everyone who helped me. I really appreciate it. :heart::heart:

#14

Hey @TheEpicMinion would you be willing to share your git repo name, and to invite me (@cori on GitHub, too) so I can test this myself? You can PM me the details if that’s preferable.

#15

I think it finnally worked. Sometimes it workes other times it doesn’t but than i’ll keep trying.
Thnx everyone who helped!! <3

1 Like