Problema al subir mi proyecto backend de node.js a glitch

Tengo un problema, estoy importando desde github mi repositorio donde se encuentra mi proyecto backend.

Lo subo y cuando quiero usar el link “live site” o pongo en la terminal de glitch para probar “npm start”, me sale error. trate de instalar las dependencias pero la verdad que no se.

Soy nuevo en esto, en especial usando glitch. el proyecto estaba en heroku, lo trate de pasar a glitch, para usar el hosting de forma gratuita, ya que es un proyecto.

El error que me aparece en la consola al poner “npm start”:
$ npm start

negocio-backend@1.0.0 start /app
babel-node src/index.js
/rbd/pnpm-volume/2ab25b67-3d3d-40fb-8963-85a6a1a69de4/node_modules/.registry.npmjs.org/mongodb/6.5.0/node_modules/mongodb/lib/admin.js:62
session: options?.session,
^
SyntaxError: Unexpected token .
at Module._compile (internal/modules/cjs/loader.js:723:23)
at Module._extensions…js (internal/modules/cjs/loader.js:789:10)
at Object.require.extensions.(anonymous function) [as .js] (/rbd/pnpm-volume/2ab25b67-3d3d-40fb-8963-85a6a1a69de4/node_modules/.registry.npmjs.org/babel-register/6.26.0/node_modules/babel-register/lib/node.js:152:7)
at Module.load (internal/modules/cjs/loader.js:653:32)
at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
at Function.Module._load (internal/modules/cjs/loader.js:585:3)
at Module.require (internal/modules/cjs/loader.js:692:17)
at require (internal/modules/cjs/helpers.js:25:18)
at Object. (/rbd/pnpm-volume/2ab25b67-3d3d-40fb-8963-85a6a1a69de4/node_modules/.registry.npmjs.org/mongodb/6.5.0/node_modules/mongodb/src/index.ts:1:1)
at Module._compile (internal/modules/cjs/loader.js:778:30)
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! negocio-backend@1.0.0 start: babel-node src/index.js
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the negocio-backend@1.0.0 start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

y el error al ingresar el link: 504 Gateway Time-out

y por las dudas si necesitan ver mi package.json.pienso que el error radica ahi:

{
“name”: “negocio-backend”,
“version”: “1.0.0”,
“description”: “backend sobre un almacen manejo de caja y stock”,
“main”: “index.js”,
“scripts”: {
“start”: “babel-node src/index.js”,
“dev”: “nodemon --exec babel-node src/index.js”
},
“keywords”: [
“crud”,
“negocio”,
“kiosko”,
“almacen”
],
“author”: “Franco Hollenstein”,
“license”: “ISC”,
“dependencies”: {
“babel-cli”: “^6.26.0”,
“babel-preset-env”: “^1.7.0”,
“cors”: “^2.8.5”,
“express”: “^4.19.2”,
“mongoose”: “^8.3.2”,
“morgan”: “^1.10.0”
},
“devDependencies”: {
“nodemon”: “^3.1.0”
}
}

Hola,
Necesitas cambiar el version de node en tu package.json:

...
"engines": {
  "node": "16.x"
}
...

(16.x es un ejemplo - ?. trabaja en node 14.0+)
Espero que esto sea útil, y que mi español sea comprensible (todavía estoy aprendiendo) :slight_smile:

1 Like

thanks for sharing