Problems With Github Export and Editing Project Name


Since a couple of days ago, trying to edit my project names do not take, and exporting to github stopped working. Is there a known problem on Glitch’s side causing these issues?


hi cpinheir,

unfortunately, I am not able to reproduce these issues. Our integration tests suite tracks these two actions too and didn’t report any problem either.

Can you provide the project name and a set of steps to follow to reproduce your issue?


  1. go to in the myprojects heading there is a circular indicator of some kind that spins forever, but my projects never appear on this page. I have to click the ‘edit code’ button under my icon to go to my projects. this is %100 repeatable.

  2. project name enchanted-jar. click project name to get to the project options window. edit project name here to cpinheir-bug. click ‘live’ button, I get a new tab that shows ‘project not found’ error. go back to project page and refresh…the project name reverts back to enchanted-jar, as if my name change never took efect. this is %100 repeatable.

  3. click project name to get to the project options window. click ‘advanced optiions’. click ‘export to github’. enter rep name of cpinheir1103/glitch-test-bug-repo—can-delete. click ok again. glitch reports successful commit, but github shows no commit. then a dialog come up on glitch: ‘connection error Our editor can’t connect to the Glitch API. Is your computer online?’. this is %100 repeatable.


I’m having similar issues, except with importing a project from GitHub. Circular indicator in the header spins forever.


Hi cpinheir,

We am really sorry to hear that, but unfortunately we cannot reproduce any of your issues :frowning:

The closer we get is the situation in which you have a broken logged-in user. So I would suggest you to log out of Glitch and try to log in again.

Thanks for the report! Let us know if this fixes the problems.

UPDATE: can you tell us which OS and browser you are using?


I’m using Win 10, Firefox 47. Neither my OS nor browser should be the issue, though, as I was using the same for the last two weeks with no problem on Glitch. It was only a couple of days ago the problem started occurring.

BTW I logged in and out, and the only difference that made is now the github import/export buttons are disabled, with ‘Grant access to import and export to a repo’ printed above the buttons. I try to click grant access, and I get the ‘connection error - Our editor can’t connect to the Glitch API. Is your computer online’ dialog again.

Strange…I completed about 10 projects for freecodecamp using Glitch in the last 2 weeks, and it was only during the last project that I started having these problems. At least I was able to complete the last project, although I couldnt name it something meaningful or check it into github. Luckily I am done with my FCC Backend projects, so I won’t need to use Glitch for now.


hi cpinheir,

I’ve tried to reproduce your issue again using Firefox, but with no luck. Excluding some kind of connectivity issues on your end, it might be related to some problems with your user token.

Is it ok for you if I use your personal token for some additional testing?

Alternatively, can you try to log in with a different user (for example using Facebook) to see if problem 1 and 2 go away? If you have a spare GitHub account, you can also try to log in with that one to see if problem 3 is solved too.

Finally, you can try to remix your project to see if that helps too.

Thanks again for your collaboration and reports!


Sure, go ahead and use my token for testing.

I tried to login with facebook, but when I click the ‘sign in with facebook’ button, it just brings me to a blank page.

Finally, remixing the projects do not help…they exhibit the same behavior.


mmmh, very strange. I am pretty sure that I will not be able to reproduce; perhaps there are networking issues, caused either by our infrastructure or by your area. I’ll let you know if I have some updates though.

The last test I ask you – whenever you have time – is to try a different browser. Either a more recent version of Mozilla, or Google Chrome. If you run these tests, keep me posted :slight_smile:

Thanks again


Switching to Chrome fixed the problems. My version of Firefox was working fine with Glitch until a couple of days ago, so maybe you guys put some changes into production that broke comparability with v47? Anyways, thanks for the help in solving the issue!


I had a similar error “Our editor can’t connect to the Glitch API”.
I confirm same issue with Firefox v47.0.2. No issues with Chrome. Might be good to ensure this is tested on different browsers versions
NOTE: in response to the fact it was a network issue, nowadays networks are more reliable than applications in general so most issues will almost never be network issues


Hey, sorry to bump this thread but it was the only one I was able to find which seemed in line with my own issues.

I’ve been trying to sign in on a work machine, and they’re only allowing an older (45) build of Firefox for us. It’s showing a blank screen when I attempt to sign in using Github.

Basically, what seems to be happening is this:

  1. I click sign in with Github
  2. I authorize Glitch on the Github app auth page
  3. I am redirected to Glitch
  4. Glitch attempts to call$TOKEN
  5. Firefox sees that we’re at and trying to ping without CORS headers, and blocks the request

I think in a lot of situations you can allow server side CORS requests without headers, which might be what is happening here, but maybe this version of Firefox is more aggressive about what it allows the client side to do?

Are there public issue pages? I would be glad to make an issue or submit a PR.


Are you definitely starting from a glitch page, and not a gomix page? It shouldn’t be calling if you started at glitch. Also, have you refreshed the browser on that machine? Is it possible that you have an older version of the editor hanging around in the cache?


Definitely, yeah - here’s a screenshot, just because it’s reasonable to think I’m wildly misdiagnosing this (I’ve disabled the token for now, but I can re-authorize at any point):

My cache shouldn’t be more than ~2 days old, fwiw. That was the first time I hopped on to Glitch using this machine.


(It is weird that it’s 503’ing on OPTIONS requests.)


We had a few references to the old name in the code, I’ve updated them to the correct name and the changes should be rolling out in the next few minutes. Thanks for the report :slight_smile:


Wonderful! Glad to be of some help :slight_smile:


I’m having a similar issue with GitHub. When I try to edit a post in an Issue it’s just not showing the Editor at all and nothing happens. This happens on all posts I do in GitHub.

Using Win 7 64 bit with the latest Google Chrome. Also reported this but to Google just in case. Really weird, it started happening about two weeks ago.


I had same problem . I fixed. Thanks !!! :red_circle: