Problems with installing the 'quick.db' module

So I tried to install quick.db for implementing a currency system of sorts, and then, this error appeared.

It seems to be rebuilding the ‘node-gyp’ module but fails because it couldn’t find it in the directory shown in the picture, but I already tried to reinstall node-gyp, even rebuilding it, and still the same error. Is there a way to fix this?

Try enable-pnpm


already tried that, same error

pnpm i quick.db

yes that’s the command I was using to install quick.db

Why not try

rm node_modules
pnpm i

Ok that seemed to work. Thank you!

1 Like

Isn’t there a whole UI?

Wdym @chessebuilderman?

If you look in package.json, there is usually a to install packages.

Ah yes. I just installed highlight.js on one of my apps using that a few seconds ago!

now it just gets stuck in this and it uses up a lot of memory

Is there such thing as a disable-pnpm command?

there is a enable-npm command that forces the project to use npm

alrighty time to whip out the more efficient yet slower commands by removing a single two letters:

rm node_modules
npm i
1 Like

the weird thing is that I tried npm i quick.db and it seems to work without any problems, but using pnpm i quick.db doesn’t work

1 Like

i tried

rm node_modules
pnpm i

and it didn’t work

Update: i ran into the same problem again, and quick.db is stuck at install.

Is it possible to use glitch.json to run this command so we don’t have to every 12 hours, because once I tried but it kept looping forever. Also that was on a boosted project, so glitch.json would run every five minutes (or create the longest wait time of the century)

edit: you might possibly be able to run it at first then throw it in glitch.json

i think this problem occured because I upgraded pnpm from version 2 to version 5, and that might’ve caused node-gyp to not install properly.