Project can't find a module which is installed


#1

Good Morning Glitch Support,

Today I was in my project and I found an error in console saying that the project can’t find the express module which is very questionable since it is installed by default on all projects in glitch. I tried downloading and removing it through console and through the package.json file but nothing worked. I hope you could find out what is the root bug behind this.

Error: https://prnt.sc/jlr17w

Note: The project is private but if you wanted to access the project just Direct Message me saying that you want access to my website which has the express error. Then I’ll give you a link to it.

Thank you
Deniernal354


#2

Try to run enable-npm in the console. Please let us know the project name so we can investigate further.


#3

Good Morning,
The project name is Valk. Thank you the command enable-npm has fixed the issue.
Thank you. :grin::+1:


#4

i’m having the same issue and i’ve done enable-npm in the console and i still keep getting that same error


#5

Hi @HunterWilson56, can you tell us the name of your project please?


#6

my projects name is loganweb @etamponi


#7

That project is private, please DM me a join link so we can view the code. Thanks.


#9

@Gareth what if i just send a screenshot of the thing you are looking for


#10

No, we need access to the project. Thanks.