Project fails to install modules

ERROR  EACCES: permission denied, open '/rbd/pnpm-volume/7f225a49-63c2-4259-bb2b-81d83eed535c/node_modules/@doctormckay/stdlib/package.json'

at Error: EACCES: permissio…

it also says


    throw err;


Error: Cannot find module 'express'

Require stack:


    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:610:15)

    at Function.Module._load (internal/modules/cjs/loader.js:526:27)

    at Module.require (internal/modules/cjs/loader.js:666:19)

    at require (internal/modules/cjs/helpers.js:16:16)

at Object.<anonymous> (


    at Module._compile (internal/modules/cjs/loader.js:759:30)

    at Object.Module._extensions..js (internal/modules/cjs/loader.js:770:10)

    at Module.load (internal/modules/cjs/loader.js:628:32)

    at Function.Module._load (internal/modules/cjs/loader.js:555:12)

    at Function.Module.runMain (internal/modules/cjs/loader.js:826:10)

while starting.
i have never seen anything like this on glitch before.

You could try remixing your project and try again.

thats the problem
i have a custom domain registered on this project and i really dont want to do that.

no thanks, it seems to be a problem with the npm package simple-markdown for some odd reason
but i cant uninstall it

1 Like

Have you tried removing it from your package.json file? That might be enough to stop it from affecting your project

nope, does nothing, same errors

1 Like

Hmmm, see if running enable-pnpm or npm rebuild will fix it.

1 Like

If that doesn’t work you could always try uninstalling the package that seems to be the problem and re-installing it:

pnpm uninstall @doctormckay/stdlib
# Or something
1 Like

new error

 ERROR  EACCES: permission denied, scandir '/rbd/pnpm-volume/7f225a49-63c2-4259-bb2b-81d83eed535c/node_modules/@bbob'

Try running pnpm clean

not a command, just shows help

Well whenever a permission denied error appears on a package, just delete it using pnpm remove <pkg>

uh well i would explain how i fixed it but it seems to have just fixed itself?


Welp, thats coding sometimes. :wink: