Project files don't appear in the file navigator GUI


#1

My project files have stopped appearing in the file navigator. All I can see is the assets directory (which is empty):

When I open the console and run ls all the files exist. Editing the files from the console using nano successfully updates them. However, they’ve simply stopped appearing in the GUI. I’ve tried running refresh but it hasn’t helped. I’ve also tried creating a remix of this project, but the problem persists in the remix.

Is this a bug with Glitch, or is there something I can do to have the files appear and be editable in the GUI again?

Cheers,

Jared


#2

Are your files within the default /app directory or are you putting them somewhere else? The editor assumes the /app will be used.


#3

It looks like this is a bug on our end. We’re looking into it.


#4

It turns out this was caused by a bug in the way we parse .gitignore files. Some of our code isn’t handling .* in .gitignore correctly. For now, we fixed it by changing your .gitignore. We’ll fix the underlying bug in the near future.


#5

Brilliant, thank you @Tim. Looks to be working now :smiley: