Project keeps reconnecting on changes, and can't fix disk issues

#1

Project Name: ree-bot-reeee
I am running into disk issues, and i cannot fix it. I have tried the console commands that are recommended. I cant even fix my packages, or anything. Please help…

#2

Hello @Ve6om,

A glitch staff member will give your project some extra space, to give you the time to run the necessary commands and do the necessary actions to clear up some space on your project! Once you are given the extra space, you will have 24 hours to clear up space before it goes back to normal!

#3

That would be great? Do you know when they would give this extra space?

#4

I do not know exactly when this will happen, but hopefully it will be within the next hour!

#5

Great, thanks. :smile:

1 Like
#6

For sql files i should put them in a .gitignore file correct?

#7

I do not think that will be necessary, and it is actually a .gitconfig file which I have there. I excluded the /app/.git file in the gitconfig file and that seemed to help, and I installed all your needed dependencies, and now everything should be fine! You are on 6mb used now so that should be ok for some time!

If you need any more help make sure to let us know!

#8

Thanks you, was getting frustrated! :laughing:

1 Like
#9

Hey @Ve6om, welcome to the Glitch forum!

I’m happy @Callum-OKane was able to help you out. However I’m unsure of the reliability of the .gitconfig method used here; it doesn’t match with the usage description of that gitconfig setting, so I’m unsure of how it will work long-term.

If your project was in the state i think it was probably in it’s also unusual that you could clear it without the temporary disk space expansion, but from the contents of your project’s Rewind (which is built on top of the project’s git repo) and the results of git log --stat it looks like your .git directory was probably deleted. If so I’m sure that helped with the space issue, but it will be only temporary; in fact if you run du -hd1 in your project’s console now you’ll note that your project is already up to 12Mb disk space consumed, so has doubled in size in the last few hours.

Noting that, you’ll probably want to add your often-changing files (the sqlite ones, I believe) to a .gitignore file to prevent your repo from consuming all your space again.

#11

Thanks i put the sql files in the .gitignore could you check and see if everything is setup correctly? I noticed my disk is going up really fast.

#12

@Ve6om

Can you re add me to your project and I will check if everything is alright!

#13

Yeah, no problem i invited you to edit

1 Like
#14

I have fixed the problem.
You had a . before everything in our .gitignore folder. I added scores* to the gitignore to stop the sqlite files from being added to .git

#15

Oh okay, thank you so much!

#16

I got another issue. All my economy commands that use the db, are giving me an error now.

#17

Can you please specify the error you are receiving?

#18

(node:120) UnhandledPromiseRejectionWarning: TypeError: Error: Target for .add(money_272167283319767040, 500) is not a number.

Everything was working fine before the gitignore, its only happening to the economy commands.

#19

never mind, just had to delete the file.