Project Not Found on form submit

Hi there,
When I submit the form on my static site I get the Project Not Found error. It uses get parameters so should be okay. It works if I go on the editor before submitting the form. Any idea on what’s wrong? I had a similar issue where my project came up as project not found until I went to the editor. Might be part of the new implementation of project hours/24/7 static sites

You need to include method=“get” in the form tag e.g

I tried this and it worked. I hope this helped!

Edit: I just realised it probably inly worked because I opened the editor before hand - might be worth a try though!

Another edit: I just tried it without opening the editor first and it works!

1 Like

Can you try sending the form to /makepolicy/index.html VS /makepolicy?

You’re serving this as a static project. With the new changes to how static sites are served without a project container, there are subtle differences. I’ve sent feedback about one such difference Broken symlinks in new containerless static hosting. Thanks for reporting this.

If you want to investigate further: make sure your site is responding with a server: AmazonS3 HTTP header when you’re trying to reproduce the failure. If it comes back [correction] without that header, then your project container is running, and things will seem to work as they did before.

1 Like

Hi. Is there anyway I can see the HTTP headers in Chrome? How would I see these? Is there anyway I can fix it and make it come up as express?

@wh0 Support got back to my email and said it was working again on their end. I don’t see the error now after 1 or 2 days. They said:

Hi there Eddie - I just went and see your projects are awake, running and the form worked. This may very well be the platform recognizing your app is static for the first time. If you find that you keep having to go to the editor of these projects to get them to work, let us know.

Thanks for trying to help - I have no idea what happened and if the error is actually fixed

You may as well continue to explain as it’s pretty interesting :slight_smile:

On Firefox it’s here in the Network tab of the developer tools

I think it would be similar on Chrome

1 Like

You should also be able to use cURL.

curl -I


hi, what’s up?

I see that you’re looking at the request headers, not the response headers

1 Like

Here are response headers:

Error only happens on a form submit

Oh, I hadn’t noticed that the header is never present on those 404 responses. But there are other ways to check if your project container is online.

Thanks for flagging this @EddiesTech! There is a bug that is preventing links that are not in the root to work after the project is idle for more than five minutes. I have reported it to the team. As soon as it has been fixed, I’ll post an update!


Awesome! Thanks for the update! Glad that it will be fixed! :slight_smile:

This bug has now been fixed.

Important note: If you already encountered a Project Not Found error due to this bug, you will need to do a hard refresh or clear your cache to see it working again.

If you continue to have issues that you believe are being caused by this bug, please contact support via the Help Center.


@tasha Cheers! That was really quick! Make sure to send my thanks to the devs! :slight_smile: