Project Not Found

My app, quartz-frost, is showing that it’s Live and the log is showing:

Launching node server.js
⚾️🙀 Your app is listening on port 3000

But when I click on Show Live or go to it takes me to - Project Not Found.

It’s been doing this each time I’ve tried over the last 12 hours or so.

I’m wondering if this is just happening to me or if it’s related to the ‘No service running on port’ error I and others were getting sporadically over the last few days.

As a side note, it seems that editing/saving files is working fine.

Sorry for the trouble - it seems to be displaying ok now. The team is continuing to work on stability improvements, so hopefully your experience will be better going forward.

Yeah it’s working fine at the moment, thanks.

yeah have the same problem with my project

i could remix, but i love the name :frowning:

It’s back now. It’ll be due to the on-going stability issues, which we’re doing our best to resolve. Thanks for your patience.

I just joined Glitch and am also having this issue.
My site is

This isn’t the same issue. Your project is working fine - you’ve defined one route at /root, which is here: If you intend to access your project at then you also need to define a route for “/“.

Okay, thank you for your help!

HI. I have the same problem with my own project and also with one that I have permission to edit it.

My own:
The one with edit permissions:

When I try to open project I get this message(see below)

Sorry about that, we’re looking into the issue. See for updates.

Hi,I’m having a problem with 2 of my sites where it says " Project Not Found.Maybe a typo? Or maybe it’s been renamed?".

It worked fine till yesterday.

hi @nrd26 - we’re currently experiencing some degraded performance with our API which affects project uptime. we’re posting updates as they come on