Project only works in with the debugger attached

Out of the sudden the project kept being stuck on the thinking face emoji. The only way to avoid that is having the debugger attached. Help appreciated :persevere:

1 Like

did you hard-code a port number? or other than that, the project logs might have some hints

1 Like

Found the fix I think: in the .env variables there was no GLITCH_DEBUGGER variable. Adding it manually fixes the infinite thinking face emoji. (it still gets deleted if I turn on and off debugging but I can add it again, dunno how to fix this tho)

Hi there, I haven’t been able to reproduce this issue, would you mind linking to your project so that we can investigate?

1 Like

Oh now it says debugger ready everytime the project is ready, even when GLITCH_DEBUGGER is set to false…

Sure! I’ve sent you an invite

OK so just to confirm what happened – you ran the debugger and then the project got stuck with the thinking face emoji, then when you added the GLITCH_DEBUGGER variable that allowed it to run, but the variable gets removed if you run the debugger again?

I don’t want to interfere with your project but if you could post the Log error you see when the project gets stuck (the one that prompted you to add the env variable) that might help us figure out what’s going on.

1 Like

The history of my problem goes like this:

  • project randomly gets stuck in the :thinking: (not in the debugging mode)
  • find out it only works when the debugger is enabled by trial and error
  • manually add the GLITCH_DEBUGGER variable and find out the project works (it gets removed if I turn the debugger on then off)
  • now it always says “:lady_beetle: Debugger ready (Search results for debugger - Glitch Support). If the debugger does not open, check your pop-up blocker.” even if the GLITCH_DEBUGGER variable is set to false

Yep so if you could share the Log output that shows when it’s stuck with the thinking face emoji that might help.

1 Like

I think I finally found the root of the problem.
I had .env variable named PORT. Changing its name makes the project work without issues

1 Like

Unless I was looking at the wrong place (the logs bar near the emoji at the bottom), the logs were empty while on :thinking: ?

OK so it sounds like the PORT var was the likely issue, hopefully it continues working now!

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.