Project wont start (sqlite?)


#1

So im getting a lot of errors with my project, things like;

WARN discord.js@11.4.2 requires a peer of bufferutil@^3.0.3 but none was installed.

and

ERROR ENOENT: no such file or directory, chmod ‘/rbd/pnpm-volume/d65fc766-9a48-49bb-8189-92d3e12ab22b/node_modules/node/bin/node’

and

Error: Cannot find module ‘/rbd/pnpm-volume/d65fc766-9a48-49bb-8189-92d3e12ab22b/node_modules/.registry.npmjs.org/sqlite3/4.0.6/node_modules/sqlite3/lib/binding/node-v64-linux-x64/node_sqlite3.node’

When i run the command that usually fixes these kinds of problems (enable-pnpm) it still errors.

These are the full logs right after running the command (enable-pnpm)
https://pastebin.com/K503Qdr5


#2

Hey @SammyWhamy we had some technical difficulties a little bit ago that could have affected your project. Can I ask you to run enable-pnpm in your project’s console one more time to see if your project was caught up in all of that and if that resolves the issue?

Sorry for the bother!


#3

Just did that, same errors again:
https://pastebin.com/1hQb1iHQ


#4

Can you share your project name so someone can take a closer look? Or at least the contents of your package.json file?


#5

Yeah sure, the project name is: official-chinobot

This is the package file in case you cant access it from the project:

Package.json
{
“name”: “Bot”,
“version”: “1.0.0”,
“description”: “”,
“main”: “index.js”,
“scripts”: {
“start”: “node MyBot.js”
},
“keywords”: ,
“author”: “”,
“license”: “MIT”,
“dependencies”: {
@babel/runtime”: “^7.2.0”,
“aniwrapper”: “^1.0.1”,
“axios”: “^0.18.0”,
“canvas”: “^2.3.1”,
“canvas-node”: “^0.3.20”,
“cron”: “^1.6.0”,
“discord-economy”: “^1.1.6”,
“discord.js”: “^11.4.2”,
“discordeco.js”: “^0.5.0”,
“express”: “^4.16.4”,
“ffmpeg”: “^0.0.4”,
“ffmpeg-binaries”: “^4.0.0”,
“fortnite”: “^4.2.2”,
“fs”: “^0.0.2”,
“google-translate-api”: “^2.3.0”,
“jpeg-turbo”: “^0.4.0”,
“kitsu-core”: “^6.4.0”,
“mal-scraper”: “^2.4.5”,
“ms”: “^2.1.1”,
“node”: “^11.10.0”,
“node-cron”: “^2.0.3”,
“node-kitsu”: “^1.1.1”,
“node-opus”: “^0.3.1”,
“node-osu”: “^1.3.2”,
“node-sqlite3”: “^0.0.3”,
“osu-api”: “^0.0.3”,
“pluralize”: “^7.0.0”,
“pubg-api-redis”: “^3.7.0”,
“qr-cairo”: “^0.0.8”,
“react-tenor”: “^1.1.0”,
“request”: “^2.88.0”,
“superagent”: “^4.0.0”,
“time”: “^0.12.0”,
“util”: “^0.11.1”,
“ytdl”: “^0.11.1”,
“ytdl-core”: “^0.29.0”,
“sqlite”: “^3.0.2”,
“sqlite3”: “^4.0.6”,
“windows-build-tools”: “^5.1.0”,
“node-gyp”: “^3.8.0”
}
}


#6

Ok, at least one problem is that you’re including node as a dependency. That confuses things and can get pnpm all gummed up in recursive package resolution. First thing I’d suggest is to remove that from your dependencies property and running enable-pnpm again.


#7

Did that, definitely changed a lot of things, but it didn’t fix it, here’s the new error log:
https://pastebin.com/C64QEkmT


#8

It hasn’t gotten fixed yet, do you have any more ideas on what i could do?


#9

remove node-gyp from the package.json aswell, and tell me if that helps in any way!


#10

Thanks a lot!
That fixed it for me


#11

Your welcome! Glad I could be of assistance :smile: