React native project expected to work on glitch?

I am teaching a summer camp on coding to teenagers and we are using Glitch. I am trying to get a solid grasp of Glitch so I am playing around with it more deeply (I’ve been using it for a few years now).

I have a project here:!/dominick-designs-react-native-app-ekadasi?

Question: is Glitch expected to load my react native project built with Expo? I imported my github project to glitch from here:

the logs say “this command requires expo CLI”

However, it seems to be stuck on “waking” and “preparing” and will not load the app. I am wondering if this is because Glitch does not install the node modules necessary to run a react app?

the logs say “this command requires expo cli”

It appears to install the Expo CLI you just need an NPM package:
npm install expo-cli --global


Try that, and good luck with your summer camp, that sounds very interesting!

thanks for the response. I tried to installed this via terminal. See screenshot here:

I tried to install using npm install expo-cli --global is this correct? Seems to be taking a long time to install? I also see a button add packages at top of the project. Is there a way to install all packages using something like npm i? Or do I need to install each package individually?

I think that installing the package via the “add packages” button should work.

Remember, Glitch hosts projects in containers. You are trying to install it on the Host, not your project. To install it, just type npm install expo-cli or add it to your packages.json file.
That should work.

1 Like

I ran this command in terminal but still getting This command requires Expo CLI. in the logs.

is my project public? Maybe you can try installing it?

Most CLIs need to be installed globally to work.