Registered Domains


#1

Hey so I registered the domain, gladenation.tk and it worked for a while. But then i needed to change the nameserver, changing it caused the CNAME records to delete and I dont remember my shw.io thing. Is there a way I can get it back?


#2

Hey @DeveloperNeb101, you should be able to point your CNAME to glitch.edgeapp.net and it should work fine. If not, let us know and we’ll look up your *.shw.io domain.


#3

Ok thank you, I will give that a try.


#4

Yea im afraid that did not work.


#5

When I look up the DNS records for that domain I don’t see anything right now. You can check at https://www.digwebinterface.com/?hostnames=gladenation.tk&type=ANY&ns=resolver&useresolver=8.8.4.4&nameservers=.

Perhaps the changes haven’t propagated yet - they can take a little while.


#6

Ok ill wait for a bit and see what happens.


#7

Also so I dont have to open a new project, why cant I use php? I tried writing the rules with .htaccess but that didnt work.


#8

Hey @DeveloperNeb101 currently only Node is officially supported on Glitch - we’re pretty tightly focussed on making that experience as good as it can possibly be. That said, you can look at projects like https://glitch.com/~lamp-poc for ways to run PHP on Glitch.

Hope this helps!


#9

Ok, thanks for that it helped me figure out alot of things bu there is still one problem. Now there is only bash but no node. And whe I try to instal node i dont have permsission


#10

You mentioned that your domain is still not working. When I look at the dig web interface I linked to before I still don’t see any DNS records; perhaps you can share a screenshot of your DNS config for us to examine?

As far as the other concern, it would be helpful to know what you’re trying to accomplish. While you could probably run Node and LAMP side-by-side in the same project, they both won’t be able to serve web requests, at least not conveniently. A good rule of thumb is that you can only have one process (Node, PHP, Python, whatever) serving requests within a given Glitch project, because we only open a single port to the outside. Perhaps you could create a new topic regarding that question?


#11

Ok, so here is a picture of my record: https://gyazo.com/45fcbb2c3d55c4cd8f9e146ba1a5d495. But what I am trying to do is point the domain to the glitch domain. But I registered it to another project, how do I switch it to another?


#12

My guess is that configuration is for a subdomain named “gladenation” of some top-level domain; we would need to see more of the config to know for sure.

If you want to move it to another project then I’ll need to remove it from the project you have it registered to. Can you give me that project name and I’ll disconnect them?


#13

Project name: jby-test

But it would be a great future feature to allow people to disconnect and connect their domains.


#14

Ok, I’ve removed both gladenation.tk and www.gladenation.tk from that domain.

We have work in our future plans for a variety of possible changes or enhancements to custom domains. Sorry for the current inconvenience!


#15

THANK YOU! You were a great help:wink: