Remix of #Remix4Change hangs with "Loading ..."


#1

I remixed the #Remix4Change template (my project is outstanding-clam), and when I ran it it hung with the message “Loading …”. I realized that I hadn’t put in the API keys, so I followed the instructions and put in keys for REACT_APP_GOOGLE_CIVIC_API, REACT_APP_OPENSTATES_API, and REACT_APP_GEOCODE_API (from geocode.xyz). Alas, I still get the same result.

I tried bringing up the debugger but it didn’t work. So it’s not obvious what to do.

There’s another environment variable in the .env file not mentioned by the instructions, REACT_APP_GOOGLE_GEOCODE_API, could it have something to do with that?

glitch-loading


Debugger Not Working
#2

Sorry for the problems. The base app is having the same issue due to an issue with a third-party API. I’ve flagged it to the team and they’ll resolve when they can.

REACT_APP_GOOGLE_GEOCODE_API looks to be a relic from a prior API the app used and isn’t referenced in the code so isn’t a cause.


#3

Weird! When I first ran into this problem the base app I had just run the base app successfully, and I didn’t think about rechecking it. Thanks for digging into it!


#4

We’ve added some additional error handling so it at least shows something, but the Open States API is still having trouble.


#5

Thanks for the update. I hate software.