[Resolved] Custom domains not working / showing "an unknown error has occurred" message

Thanks, I’ve contacted them, hopefully they respond soon! :grinning:

4 Likes

I’m sorry that you are getting this error! This is actually related as we are having trouble connecting via the fly api. For this reason, I have merged your post here so that you will be notified once this is fixed.

5 Likes

Hi @tasha
Have you ever looked into alternatives to fly.io that could help you set up your reverse proxy domains thing? Or make your own software to do so, like @ihack2712’s ‘Glix’? Fly.io have said you are using deprecated features of their service, so it might be time for a change.

It seems to me that you are kinda placing all the stress on fly.io when they don’t get much benefit from it. Have you ever thought about the possibility that fly.io may not be the best partner and may not fix everything for you. Mind you, I don’t know how the partnership works

3 Likes

An in house system wouldn’t be a bad idea, just not sure if that would mess up all the current custom domains.

3 Likes

its technically is possible with their current system, they might have to tweak it a bit but they already use reverse proxies from the *.glitch.me domain to port 3000 on (what im guessing is) a docker container. it would break all custom domains, but they could keep legacy support for old custom domains still under fly.io

Support can once again remove custom domains from projects! If you are currently experiencing any of the following, please contact support via the Help Center:

  • Custom domain that was working suddenly stopped working
  • You are trying to add a custom domain to your project and you get a “this domain is already in use” message.
  • You are trying to add a custom domain your project and you get an “an unknown error has occurred” message.

Folks who have already sent in support requests about this will receive a response shortly!

6 Likes

Thanks for the update!

3 Likes

Are we able to add our own custom domains now, or is that still broken? Since I’m still getting the exact same error as I reported in my post.

It has become clear that the bug is still affecting custom domains. Our engineers are focusing on fixing this now. I will post an update here once it has been fixed.

1 Like

I’ve been trying to use my custom domain with glitch and it keeps saying ‘An unknown error has occurred.’ I tried this with several domains and in several accounts and several projects, I saw someone asked about it and someone from the glitch staff said it is fixed now but I still can’t do it, am I doing something wrong? Can you do it on your end? Or what should I do?
image

Yep, glitch has been having issues with this recently. Please reach out to support@glitch.com with this issue.

Yeah I already did no response though.

How long has it been?

Over 2 months, I sent another email today as well.

1 Like

Glitch has said that they are having connection issues with their domain partner, https://fly.io. They said that they do not have access to remove domains from projects or look at the error details. They will let us know when its fixed.

3 Likes

Hi @kemosaf, I’m not seeing any support requests from the email that is connected to your account. Do you have a support ticket number? If so, please let me know so I can look it up.

Soooo
I tried to connect a custom domain

But i get this error
Plz help

Please contact support@glitch.com. Glitch is having issues with custom domains.

2 Likes

I want to add a custom domain to my Glitch Project, but I am facing such an error. I can’t understand. Can you help me? error: An unknown error has occurred image . https://prnt.sc/ugiv17