[Resolved] Custom domains not working / showing "an unknown error has occurred" message

Thanks for the update!


Are we able to add our own custom domains now, or is that still broken? Since I’m still getting the exact same error as I reported in my post.

It has become clear that the bug is still affecting custom domains. Our engineers are focusing on fixing this now. I will post an update here once it has been fixed.

1 Like

I’ve been trying to use my custom domain with glitch and it keeps saying ‘An unknown error has occurred.’ I tried this with several domains and in several accounts and several projects, I saw someone asked about it and someone from the glitch staff said it is fixed now but I still can’t do it, am I doing something wrong? Can you do it on your end? Or what should I do?

Yep, glitch has been having issues with this recently. Please reach out to support@glitch.com with this issue.

Yeah I already did no response though.

How long has it been?

Over 2 months, I sent another email today as well.

1 Like

Glitch has said that they are having connection issues with their domain partner, https://fly.io. They said that they do not have access to remove domains from projects or look at the error details. They will let us know when its fixed.


Hi @kemosaf, I’m not seeing any support requests from the email that is connected to your account. Do you have a support ticket number? If so, please let me know so I can look it up.

I tried to connect a custom domain

But i get this error
Plz help

Please contact support@glitch.com. Glitch is having issues with custom domains.


I want to add a custom domain to my Glitch Project, but I am facing such an error. I can’t understand. Can you help me? error: An unknown error has occurred image . https://prnt.sc/ugiv17


Glitch has been having some issues with custom domains recently. You should contact support@glitch.com and report this to them.

Merhaba acaba domainimi www. olmadan nasıl glitche kaydederim CNAME kayıtlarında www veya başka bir şey istiyor Şimdiden teşekkürler

Ok, so to do this you will want to open the terminal and type:
ping glitch.edgeapp.net

The result should contain an IP, such as 12.34.567.1. Open your DNS and create an A record for @ pointing to that IP. That should do the trick!

It should also be noted that Glitch is having some issues with custom domains right now.

Good luck!


Not working

Glitch is currently having issues with custom domains, check back later.

Did you just copy and paste the example IP address posted by @RiversideRocks?

1 Like