[Resolved] Service Incident Update: Projects Loading Slowly or Not At All, NPM Reinstalls, & Missing Code

Did you try with df -h in your terminal?

This is the result @wh0

1 Like

(This one has a line that’s missing in the first one)

Did you try with git prune or removing useless packages?

I’m pretty sure I’m using all my packages

Omg I think git prune fixed it

I’ll post something when it’s done

Okay, i got it successfully.

This happened

And I’m getting the same can’t find module errors again. What should I do??

this kind of looks like pnpm isn’t set up right. it’s not supposed to put a registry in /rbd/pnpm-volume/store/2. it’s supposed to connect to a server through a socket in that directory, I think. I’m a beginner at this stuff, but that’s what my container has, anyway.

Could you show the output of this:

pnpm server status

On mine the output is

store: /rbd/pnpm-volume/store/2
process id: 31766
remote prefix: http://unix:/rbd/pnpm-volume/store/2/server/socket:

edit: oh neat, the pnpm author built the store system for Glitch https://dev.to/zkochan/comment/416g


1 Like

Weird, i use npm, not pnpm. With using npm, this issue isn’t occurring in any way.

As i mentioned, in my case i only used git prune && git gc and it fixed my issue.

So does anyone else have a solution…

Contact Glitch support (support@glitch.com) and they can likely give some more advice to help you work it out. Really sorry that this is happening!

Ok I’ll try to contact them

1 Like

when I ran pnpm i I got this:
ENOSPC: no space left on device, mkdir ‘/rbd/pnpm-volume/93b21c41-037b-43a7-a1b3-7415a059ac51/node_modules/.registry.npmjs.org/better-sqlite3/6.0.1’

what does better-sqlite3 have to do with this!?!?!?

There is a issue with Glitch’s end. The same issue happening to me even i deleted the rewind cache. @glitch_support Can you response to this message, or listening to the community and fixing the current issues.

1 Like

Thanks for getting back to us with an update. Again, there’s gonna be no solutions here, because this stuff is out of our control. But this one is interesting. This path makes sense: it’s where the modules get “copied” to by pnpm. This area appears to be on a btrfs filesystem, which makes sense, because it has neat features that would allow you to copy these npm packages around without using duplicate disk space. But it also has this additional complexity that even if you’re not out of space in terms of bytes available, you can run out of “metadata chunks.”

Running out of metadata chunks–seems like it could happen if the disk were storing a bunch of node modules, which tend to have many small files.

According to this thing on stackexchange, there’s a command one could run to “balance” the free space with free metadata chunks. But unfortunately we’re not in charge of that disk as a whole, and we users can’t do anything about this.