Running python script via curl fails to run script properly

when i try to run my python script by curl:

(input fails)

product number: Traceback (most recent call last):
  File "<stdin>", line 45, in <module>
EOFError: EOF when reading a line

When i try to run by python:
(input works, but sadly when i run ‘1’

Traceback (most recent call last):
     File "/dev/fd/63", line 56, in <module>
      File "<string>", line 7, in <module>
ModuleNotFoundError: No module named 'xent_config'

Module exists, what gives?

check: https://glitch.com/edit/#!/bubble-com

2 Likes

@17lwinn Check, the recent posts… Xent is no more…

1 Like

I vaguely recall you were discussing this in a different thread. Could you describe what technique you went with here, for completeness?

1 Like

okay, so you might remember towards the bottom ihack gave me this command:

curl bubble-com/main.py | python3

but when it came to input you get that first error- which was in my mind unfixable, when I ran with process substitution in python-

python3 <(curl "https://bubble-com.glitch.me/main.py" -s -N)

You get our second error- nothing wrong with the code as far as i can see


btw @Jonyk56, this isn’t going to be Xent as we know it

2 Likes

so… guess what, the xent_config.py file must also be client side, for it to work, which is very difficult… :thinking:

2 Likes

Hmmm, maybe it might work