.save files being created -- also having very consistent connection issues


#1

I am consistently having to delete .save files (ie: bot.js.save.454gyuteh3) that are being created within folders in my project. I’m not sure where these are coming from but is there some setting I can use to avoid these being created? I’ve added a workaround to not include these files, but if possible I’d like to remove them and stop them from returning every time I edit something.

I am also having connection issues on my account (every time I try to edit my files, I get the “reconnecting…” message and nothing saves). I am using the same connection as others on my team who are able to edit scripts without any problems. This only started happening this morning.

Thank you in advance for any help! @Gareth This may be due to the recent Glitch updates, but I’m not entirely sure.


#2

Hey @esalling23!

I’ve had issues like this happen to me before as well, although not recently. It happened 2-3 days ago.


#3

Good to know I’m not alone! :slight_smile:
I believe it has something to do with my project hitting size limits - at least the reconnection issue has gone away when I removed old files to reduce my project size. I’m still seeing the .save files being created though.


#4

You can try and free up space in your project. git gc and git prune can help reclaim some space, and if you are not concerned about losing your git history, you can remove the .git directory using rm -rf .git. All from the console, available under advanced options from the top-left project info menu in the editor.


#5

Hi Gareth - thanks! I found some earlier questions specific to size while I was trying to figure out what the actual issue was and tried those commands. They did reduce the size a bit, from 100% to 96% full. Are there any options for projects that need to go past the Glitch size limits?

In addition, is there anything I can do about the .save files? Not sure they are taking up much space, but they are certainly cluttering up my files.


#6

Those save files are part of a feature we’re in the middle of implementing. It sounds like they’re sticking around because you’re running into the size limit.

Usually, the main thing that takes up disk space is your node_modules. If you haven’t yet run enable-pnpm in the console, you can do that - it should save a ton of space in most cases. When you’re using pnpm, the size of your node_modules folder doesn’t count towards your project size limit. If you run into trouble, you can run enable-npm to get back to where you are now.