Socket.io broken on latest glitch?

Hello, I have a few projects using socket.io. All of a sudden, they no longer work. First error I see in the logs now:

npm WARN ws@7.4.1 requires a peer of bufferutil@^4.0.1 but none is installed. You must install peer dependencies yourself.

npm WARN ws@7.4.1 requires a peer of utf-8-validate@^5.0.2 but none is installed. You must install peer dependencies yourself.

So I added these packages and don’t see an error anymore yet socket.io server code seems not to run currently

These are just warnings, they don’t matter. Anything else in the log?

1 Like

Not seeing any other errors. I will try stripping it to a minimal example and repost.

Sounds like you upgraded through a major version, 3.0 recently came out I think.
This sections shows how to integerate socketio with express

It seems like they might have changed the way you get the socketio middleware

2 Likes